summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/usbredir/usbredir-0.4.4.ebuild')
-rw-r--r--sys-apps/usbredir/usbredir-0.4.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/usbredir/usbredir-0.4.4.ebuild b/sys-apps/usbredir/usbredir-0.4.4.ebuild
new file mode 100644
index 000000000000..75aa8bd0448a
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-0.4.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic
+
+DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="http://spice-space.org/page/UsbRedir"
+SRC_URI="http://spice-space.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="ChangeLog README* TODO *.txt"
+
+src_configure() {
+ # http://bugs.freedesktop.org/show_bug.cgi?id=54643
+ append-cflags -Wno-error
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}