summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/vbetool/vbetool-1.1.ebuild')
-rw-r--r--sys-apps/vbetool/vbetool-1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/vbetool/vbetool-1.1.ebuild b/sys-apps/vbetool/vbetool-1.1.ebuild
new file mode 100644
index 000000000000..b201b640ff97
--- /dev/null
+++ b/sys-apps/vbetool/vbetool-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Run real-mode video BIOS code to alter hardware state (i.e. reinitialize video card)"
+HOMEPAGE="http://www.codon.org.uk/~mjg59/vbetool/"
+SRC_URI="http://www.codon.org.uk/~mjg59/vbetool/download/vbetool-1.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib
+ sys-apps/pciutils
+ >=dev-libs/libx86-1.1-r1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0-build.patch
+ eaclocal # temp fix for #439614
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-x86emu
+}