summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xinetd/xinetd-2.3.15.3-r2.ebuild')
-rw-r--r--sys-apps/xinetd/xinetd-2.3.15.3-r2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/xinetd/xinetd-2.3.15.3-r2.ebuild b/sys-apps/xinetd/xinetd-2.3.15.3-r2.ebuild
new file mode 100644
index 000000000000..92bc834e7df9
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.15.3-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic systemd toolchain-funcs autotools
+
+DESCRIPTION="powerful replacement for inetd"
+HOMEPAGE="https://github.com/xinetd-org/xinetd https://github.com/openSUSE/xinetd"
+SRC_URI="https://github.com/openSUSE/xinetd/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="perl rpc selinux tcpd"
+
+DEPEND="
+ rpc? ( net-libs/libtirpc:= )
+ selinux? ( sys-libs/libselinux )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+"
+RDEPEND="
+ ${DEPEND}
+ perl? ( dev-lang/perl )
+"
+DEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-rpc.patch #651838
+ "${FILESDIR}"/${P}-rpc-configure.patch #651838
+)
+
+src_prepare() {
+ default
+ eautoreconf
+
+ sed -i \
+ -e 's:/usr/bin/kill:/bin/kill:' \
+ "contrib/${PN}.service" || die
+}
+
+src_configure() {
+ econf \
+ $(use_with tcpd libwrap) \
+ $(use_with selinux labeled-networking) \
+ $(use_with rpc) \
+ --with-loadavg
+}
+
+src_install() {
+ default
+
+ use perl || rm -f "${ED}"/usr/sbin/xconv.pl
+
+ newinitd "${FILESDIR}"/xinetd.rc6 xinetd
+ newconfd "${FILESDIR}"/xinetd.confd xinetd
+ systemd_dounit "contrib/${PN}.service"
+
+ newdoc contrib/xinetd.conf xinetd.conf.dist.sample
+ dodoc README.md CHANGELOG
+}