summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/grub-2.02-r4.ebuild9
-rw-r--r--sys-boot/grub/grub-2.04_rc1.ebuild9
-rw-r--r--sys-boot/grub/grub-9999.ebuild9
3 files changed, 9 insertions, 18 deletions
diff --git a/sys-boot/grub/grub-2.02-r4.ebuild b/sys-boot/grub/grub-2.02-r4.ebuild
index e7fdf86942fe..2215a61ff455 100644
--- a/sys-boot/grub/grub-2.02-r4.ebuild
+++ b/sys-boot/grub/grub-2.02-r4.ebuild
@@ -58,7 +58,7 @@ HOMEPAGE="https://www.gnu.org/software/grub/"
# Includes licenses for dejavu and unifont
LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
-IUSE="debug device-mapper doc efiemu +fonts mount multislot nls static sdl test +themes truetype libzfs"
+IUSE="device-mapper doc efiemu +fonts mount multislot nls static sdl test +themes truetype libzfs"
GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
@@ -75,9 +75,7 @@ REQUIRED_USE="
COMMON_DEPEND="
app-arch/xz-utils
>=sys-libs/ncurses-5.2-r5:0=
- debug? (
- sdl? ( media-libs/libsdl )
- )
+ sdl? ( media-libs/libsdl )
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
libzfs? ( sys-fs/zfs )
mount? ( sys-fs/fuse:0 )
@@ -211,14 +209,13 @@ grub_configure() {
--program-prefix=
--libdir="${EPREFIX}"/usr/lib
--htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
- $(use_enable debug mm-debug)
$(use_enable device-mapper)
$(use_enable mount grub-mount)
$(use_enable nls)
$(use_enable themes grub-themes)
$(use_enable truetype grub-mkfont)
$(use_enable libzfs)
- $(use sdl && use_enable debug grub-emu-sdl)
+ $(use_enable sdl grub-emu-sdl)
${platform:+--with-platform=}${platform}
# Let configure detect this where supported
diff --git a/sys-boot/grub/grub-2.04_rc1.ebuild b/sys-boot/grub/grub-2.04_rc1.ebuild
index 38c9444f69aa..5970936ad665 100644
--- a/sys-boot/grub/grub-2.04_rc1.ebuild
+++ b/sys-boot/grub/grub-2.04_rc1.ebuild
@@ -52,7 +52,7 @@ HOMEPAGE="https://www.gnu.org/software/grub/"
# Includes licenses for dejavu and unifont
LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
-IUSE="debug device-mapper doc efiemu +fonts mount nls static sdl test +themes truetype libzfs"
+IUSE="device-mapper doc efiemu +fonts mount nls static sdl test +themes truetype libzfs"
GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
@@ -95,9 +95,7 @@ BDEPEND="
COMMON_DEPEND="
app-arch/xz-utils
>=sys-libs/ncurses-5.2-r5:0=
- debug? (
- sdl? ( media-libs/libsdl )
- )
+ sdl? ( media-libs/libsdl )
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
libzfs? ( sys-fs/zfs )
mount? ( sys-fs/fuse:0 )
@@ -211,14 +209,13 @@ grub_configure() {
--program-prefix=
--libdir="${EPREFIX}"/usr/lib
--htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
- $(use_enable debug mm-debug)
$(use_enable device-mapper)
$(use_enable mount grub-mount)
$(use_enable nls)
$(use_enable themes grub-themes)
$(use_enable truetype grub-mkfont)
$(use_enable libzfs)
- $(use sdl && use_enable debug grub-emu-sdl)
+ $(use_enable sdl grub-emu-sdl)
${platform:+--with-platform=}${platform}
# Let configure detect this where supported
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 38c9444f69aa..5970936ad665 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -52,7 +52,7 @@ HOMEPAGE="https://www.gnu.org/software/grub/"
# Includes licenses for dejavu and unifont
LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
-IUSE="debug device-mapper doc efiemu +fonts mount nls static sdl test +themes truetype libzfs"
+IUSE="device-mapper doc efiemu +fonts mount nls static sdl test +themes truetype libzfs"
GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
@@ -95,9 +95,7 @@ BDEPEND="
COMMON_DEPEND="
app-arch/xz-utils
>=sys-libs/ncurses-5.2-r5:0=
- debug? (
- sdl? ( media-libs/libsdl )
- )
+ sdl? ( media-libs/libsdl )
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
libzfs? ( sys-fs/zfs )
mount? ( sys-fs/fuse:0 )
@@ -211,14 +209,13 @@ grub_configure() {
--program-prefix=
--libdir="${EPREFIX}"/usr/lib
--htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
- $(use_enable debug mm-debug)
$(use_enable device-mapper)
$(use_enable mount grub-mount)
$(use_enable nls)
$(use_enable themes grub-themes)
$(use_enable truetype grub-mkfont)
$(use_enable libzfs)
- $(use sdl && use_enable debug grub-emu-sdl)
+ $(use_enable sdl grub-emu-sdl)
${platform:+--with-platform=}${platform}
# Let configure detect this where supported