summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/os-prober')
-rw-r--r--sys-boot/os-prober/Manifest1
-rw-r--r--sys-boot/os-prober/os-prober-1.66.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sys-boot/os-prober/Manifest b/sys-boot/os-prober/Manifest
index a4a0a46ade37..8f23d4a1779c 100644
--- a/sys-boot/os-prober/Manifest
+++ b/sys-boot/os-prober/Manifest
@@ -2,3 +2,4 @@ DIST os-prober_1.53.tar.gz 26132 SHA256 58c47274b8e531fdc8b525fa5903885b92dbc3ee
DIST os-prober_1.57.tar.gz 26717 SHA256 d63c6cbb825a7e411aac5e4805edc6db2fbf77a59282b71c10bd29723b8d860c SHA512 b5c2af89e3a69688d3585ea52fd57e48fe85844a9ad5372735f57b9a780027e2f96cc86b1307be7e24b9e141ecea3d4c26316c0cc043eb7a97d24ee46bb07665 WHIRLPOOL 918015a67a3b6530788c093e866cfaa0ae0cd717f869677270b6c6f401d3c891378312f58c9e5f3ec9c22b566f09c33eeb3b0e71839b8a0ca47f530f900c974c
DIST os-prober_1.62.tar.gz 28592 SHA256 5f25decfef22318c4c705594c9c2049e8d1e662fc8817a4a8e5b114cd26ee1c1 SHA512 6d888de867b5420767491ba66e3ebc0796320bfea5c7efc9a1eabf9bb8290b25e5292fc9b22ffc24101a9faf0e846c85fb1ba73fa1ec44a2c0c0c198c89ea49a WHIRLPOOL e98b54c769fa9a199b1f64b37ccca801499ed3e6e0dbe1189a63220cbbfdca1b1e8411a8d4b4cb6a15b48a83cde39c887288d2f40c3b69d276ddfdaf4e178b96
DIST os-prober_1.65.tar.xz 24712 SHA256 c4a7661a52edae722f7e6bacb3f107cf7086cbe768275fadf5398d04360bfc84 SHA512 64dd9042a26dc859d9186bb48545d85b1a369d00a93b5045c420eac0c4b672ab32cb6028eada5f1cc21c8ab9386c35b8eedb79bc7975faf7b0a7b2841b284f53 WHIRLPOOL 397a92312b018fa08b2e838bc6b85fa4d55502dfb8e8725c79f4a0ae397e3bd258a7bb302f74b2293cd85f4ddabf4cba75ff2b4b57fa9904094c3a50e1ace36e
+DIST os-prober_1.66.tar.xz 24904 SHA256 ab66eab63223d651cb6f9221ddffc958521b13edee4996c4fd87f08cb1955057 SHA512 6aaa2787be9ea522ae71b8c65fc04bb05af233c81e2a8cd0c27b79d6f8c697c5585b5f5fce91c67eab3bbc782e29087fb22db2626609702ab272a398e59ce333 WHIRLPOOL 12d058e78ddd168938b0160b8a2348b497d24c17b99a30a34edcd3e663e8c57eded8d85d02d97c85ad936aadce123387c85dd9c3f0510bf200a9fbf632fd95bf
diff --git a/sys-boot/os-prober/os-prober-1.66.ebuild b/sys-boot/os-prober/os-prober-1.66.ebuild
new file mode 100644
index 000000000000..9e98b17baa1b
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.66.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # use default GNU rules
+ rm Makefile || die 'rm Makefile failed'
+ # Fix references to grub-mount
+ sed -i -e 's:grub-mount:grub2-mount:g' \
+ common.sh \
+ linux-boot-probes/common/50mounted-tests \
+ os-probes/common/50mounted-tests
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ # Note: as no shared libraries are installed, /usr/lib is correct
+ exeinto /usr/lib/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/lib/$dir
+ doexe $dir/common/*
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/*
+ fi
+ if [[ -d $dir/$debarch/efi ]]; then
+ exeinto /usr/lib/$dir/efi
+ doexe $dir/$debarch/efi/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/lib/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ dodoc README TODO debian/changelog
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}