summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/refind/refind-0.11.3.ebuild')
-rw-r--r--sys-boot/refind/refind-0.11.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-boot/refind/refind-0.11.3.ebuild b/sys-boot/refind/refind-0.11.3.ebuild
index 511e74dce7aa..61fa68128311 100644
--- a/sys-boot/refind/refind-0.11.3.ebuild
+++ b/sys-boot/refind/refind-0.11.3.ebuild
@@ -101,6 +101,9 @@ src_compile() {
AS="$(tc-getAS)"
LD="$(tc-getLD)"
AR="$(tc-getAR)"
+ GNUEFILIB="/usr/$(get_libdir)"
+ EFILIB="/usr/$(get_libdir)"
+ EFICRT0="/usr/$(get_libdir)"
RANLIB="$(tc-getRANLIB)"
OBJCOPY="$(tc-getOBJCOPY)"
GNUEFI_LDFLAGS="-T \$(GNUEFI_LDSCRIPT) -shared -nostdlib -Bsymbolic \
@@ -177,7 +180,7 @@ pkg_postinst() {
elog ""
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog "refind-install requires additional packages to be fully functional:"
- elog " app-crypt/sbsigntool for binary signing for use with SecureBoot"
+ elog " app-crypt/sbsigntools for binary signing for use with SecureBoot"
elog " sys-boot/efibootmgr for writing to NVRAM"
elog " sys-block/parted for automatic ESP location and mount"
elog ""