summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/hpx/hpx-1.2.1.ebuild')
-rw-r--r--sys-cluster/hpx/hpx-1.2.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-cluster/hpx/hpx-1.2.1.ebuild b/sys-cluster/hpx/hpx-1.2.1.ebuild
index 64c2d82ce771..92be9c4426d8 100644
--- a/sys-cluster/hpx/hpx-1.2.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.2.1.ebuild
@@ -13,7 +13,7 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 python-any-r1
+inherit cmake fortran-2 python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
@@ -64,16 +64,16 @@ src_configure() {
mycmakeargs+=( -DHPX_WITH_MALLOC=system )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
# avoid over-suscribing
- cmake-utils_src_make -j1 tests
+ cmake_build -j1 tests
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples; then
mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
insinto /usr/share/doc/${PF}