summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/teleport/teleport-9999.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/sys-cluster/teleport/teleport-9999.ebuild b/sys-cluster/teleport/teleport-9999.ebuild
index a16c3c133705..1111454a6462 100644
--- a/sys-cluster/teleport/teleport-9999.ebuild
+++ b/sys-cluster/teleport/teleport-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils golang-build systemd user
+inherit golang-build systemd
DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
HOMEPAGE="https://gravitational.com/teleport"
@@ -15,29 +15,23 @@ if [[ ${PV} == "9999" ]] ; then
else
inherit golang-vcs-snapshot
SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm"
fi
+IUSE="pam"
LICENSE="Apache-2.0"
+RESTRICT="test strip"
SLOT="0"
-IUSE=""
-DEPEND="
- app-arch/zip
- >=dev-lang/go-1.7"
-RDEPEND=""
+DEPEND="app-arch/zip"
+RDEPEND="pam? ( sys-libs/pam )"
src_compile() {
- BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
- pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
- zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
- popd >/dev/null || die
- cat "${S}/src/${EGO_PN%/*}/build/webassets.zip" >> "src/${EGO_PN%/*}/build/${PN}" || die
- zip -q -A "${S}/src/${EGO_PN%/*}/build/${PN}" || die
+ BUILDFLAGS="" GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
}
src_install() {
- dodir /var/lib/${PN} /etc/${PN}
+ keepdir /var/lib/${PN} /etc/${PN}
dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
insinto /etc/${PN}
@@ -46,10 +40,10 @@ src_install() {
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
}
src_test() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
}