summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils-apple/binutils-apple-3.2.ebuild')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-3.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-3.2.ebuild b/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
index e60586c9425b..4ccf5b257b9c 100644
--- a/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
@@ -134,7 +134,7 @@ compile_ld64() {
# but not on tiger.
[[ ${CHOST} == *-apple-darwin8 ]] && \
append-flags -isystem "${S}"/${CCTOOLS}/include/
- emake || die "emake failed for ld64"
+ emake
use test && emake build_test
}
@@ -146,13 +146,12 @@ compile_cctools() {
EFITOOLS= \
COMMON_SUBDIRS='libstuff ar misc otool' \
SUBDIRS_32= \
- RC_CFLAGS="${CFLAGS}" OFLAG="${CFLAGS}" \
- || die "emake failed for the cctools"
+ RC_CFLAGS="${CFLAGS}" OFLAG="${CFLAGS}"
+
cd "${S}"/${CCTOOLS}/as
emake \
BUILD_OBSOLETE_ARCH= \
- RC_CFLAGS="-DASLIBEXECDIR=\"\\\"${EPREFIX}${LIBPATH}/\\\"\" ${CFLAGS}" \
- || die "emake failed for as"
+ RC_CFLAGS="-DASLIBEXECDIR=\"\\\"${EPREFIX}${LIBPATH}/\\\"\" ${CFLAGS}"
}
src_compile() {