summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-11.2.1_p20220414.ebuild')
-rw-r--r--sys-devel/gcc/gcc-11.2.1_p20220414.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-11.2.1_p20220414.ebuild b/sys-devel/gcc/gcc-11.2.1_p20220414.ebuild
new file mode 100644
index 000000000000..fc2cb2de2258
--- /dev/null
+++ b/sys-devel/gcc/gcc-11.2.1_p20220414.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PATCH_VER="4"
+PATCH_GCC_VER="11.3.0"
+MUSL_VER="1"
+MUSL_GCC_VER="11.3.0"
+
+MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
+MY_P=${PN}-${MY_PV}
+GCC_TARBALL_SRC_URI="https://mirrorservice.org/sites/sourceware.org/pub/gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+inherit toolchain
+
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Technically only if USE=hardened *too* right now, but no point in complicating it further.
+# If GCC is enabling CET by default, we need glibc to be built with support for it.
+# bug #830454
+RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
+DEPEND="${RDEPEND}"
+BDEPEND="${CATEGORY}/binutils[cet(-)?]"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ eapply_user
+}