summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/obconf-qt/obconf-qt-0.1.0.ebuild')
-rw-r--r--x11-misc/obconf-qt/obconf-qt-0.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/obconf-qt/obconf-qt-0.1.0.ebuild b/x11-misc/obconf-qt/obconf-qt-0.1.0.ebuild
new file mode 100644
index 000000000000..1298177f6835
--- /dev/null
+++ b/x11-misc/obconf-qt/obconf-qt-0.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Openbox window manager configuration tool"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+S=${WORKDIR}
+
+RDEPEND="dev-libs/glib:2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-wm/openbox:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"