summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/pypanel')
-rw-r--r--x11-misc/pypanel/Manifest1
-rw-r--r--x11-misc/pypanel/metadata.xml19
-rw-r--r--x11-misc/pypanel/pypanel-2.4-r1.ebuild33
3 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/pypanel/Manifest b/x11-misc/pypanel/Manifest
new file mode 100644
index 000000000000..7f42872b58fb
--- /dev/null
+++ b/x11-misc/pypanel/Manifest
@@ -0,0 +1 @@
+DIST PyPanel-2.4.tar.gz 29857 SHA256 4e612b43c61b3a8af7d57a0364f6cd89df481dc41e20728afa643e9e3546e911
diff --git a/x11-misc/pypanel/metadata.xml b/x11-misc/pypanel/metadata.xml
new file mode 100644
index 000000000000..ca302fdca57c
--- /dev/null
+++ b/x11-misc/pypanel/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <longdescription>
+PyPanel is a lightweight panel/taskbar for X11 window managers that can
+be easily customized to match any desktop theme or taste.
+
+Some of the customizable features include transparency w/ shading, panel
+dimensions and location, font type and colors, button events/actions,
+clock and workspace name display.
+
+PyPanel should work with any WM that supports the EWMH specification.
+The following have been tested: Kahakai, Openbox3, PekWM, WindowMaker.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pypanel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/pypanel/pypanel-2.4-r1.ebuild b/x11-misc/pypanel/pypanel-2.4-r1.ebuild
new file mode 100644
index 000000000000..37149e2f5e85
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-2.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+MY_PN=${PN/pyp/PyP}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A lightweight panel/taskbar for X11 window managers"
+HOMEPAGE="http://pypanel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ dev-python/python-xlib
+ sys-apps/sed
+ media-libs/imlib2[X]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}