summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qtfm/qtfm-5.5.ebuild')
-rw-r--r--x11-misc/qtfm/qtfm-5.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/qtfm/qtfm-5.5.ebuild b/x11-misc/qtfm/qtfm-5.5.ebuild
new file mode 100644
index 000000000000..80e89408ed6f
--- /dev/null
+++ b/x11-misc/qtfm/qtfm-5.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit fdo-mime qt4-r2
+
+DESCRIPTION="A small, lightweight file manager for desktops based on pure Qt"
+HOMEPAGE="http://www.qtfm.org/"
+SRC_URI="http://www.qtfm.org/${P}.tar.gz?attredirects=0 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# file is for LIBS += -lmagic
+RDEPEND="sys-apps/file
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "/^docs.path/s:qtfm:${PF}:" \
+ -e '/^docs.files/s: COPYING::' \
+ ${PN}.desktop || die
+ sed -i \
+ -e '/MimeType=/s|$|;|' \
+ -e '/Categories=/s|$|;System;FileTools;|' \
+ ${PN}.desktop || die
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }