summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild')
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
new file mode 100644
index 000000000000..7269d23666c5
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="trayer fork with multi monitor support, cleaned up codebase and other fancy stuff"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/tarball/${P/-srg/} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc CHANGELOG CREDITS README TODO
+}