summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/viewglob/viewglob-2.0.4-r1.ebuild')
-rw-r--r--x11-misc/viewglob/viewglob-2.0.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild b/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..20cdb09ecaaf
--- /dev/null
+++ b/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils readme.gentoo
+
+DESCRIPTION="Graphical display of directories and globs referenced at the shell prompt"
+HOMEPAGE="http://viewglob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewglob/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ || ( app-shells/bash:* app-shells/zsh )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
+
+src_install() {
+ autotools-utils_src_install
+ readme.gentoo_src_install
+}