summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xdo/xdo-0.3.ebuild')
-rw-r--r--x11-misc/xdo/xdo-0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/xdo/xdo-0.3.ebuild b/x11-misc/xdo/xdo-0.3.ebuild
new file mode 100644
index 000000000000..caa8f0c26fe5
--- /dev/null
+++ b/x11-misc/xdo/xdo-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Small X utility to perform elementary actions on windows"
+HOMEPAGE="https://github.com/baskerville/xdo/"
+SRC_URI="https://github.com/baskerville/xdo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libxcb
+ x11-libs/xcb-util-wm"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e '/CFLAGS += -Os/d' \
+ -e '/LDFLAGS += -s/d' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}