summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xdotool/xdotool-2.20101012.3049.ebuild')
-rw-r--r--x11-misc/xdotool/xdotool-2.20101012.3049.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/x11-misc/xdotool/xdotool-2.20101012.3049.ebuild b/x11-misc/xdotool/xdotool-2.20101012.3049.ebuild
deleted file mode 100644
index fd160239a599..000000000000
--- a/x11-misc/xdotool/xdotool-2.20101012.3049.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-
-inherit eutils toolchain-funcs flag-o-matic multilib
-
-DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
-HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
-SRC_URI="https://semicomplete.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples"
-
-DEPEND="x11-libs/libXtst
- x11-libs/libX11"
-RDEPEND="${DEPEND}"
-
-# The test wants to manualy start Xvfb, wont use VirtualX and it tries
-# to run a full gnome-session. For such a tiny application i consider
-# it overkill to rewrite the test scripts to not use it's own X server
-# and add a full blown gnome just to run the tests.
-RESTRICT="test"
-
-src_prepare() {
- sed -e "s/installheader post-install$/installheader/" \
- -i Makefile || die "sed failed"
-}
-
-src_compile() {
- tc-export CC LD
- default
-}
-
-src_install() {
- emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
-
- dodoc CHANGELIST README
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}