summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/gnome-terminal')
-rw-r--r--x11-terms/gnome-terminal/Manifest2
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.24.2.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index d3ca2f5ecaff..566949ba8790 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -1,2 +1,4 @@
DIST gnome-terminal-3.22.2.tar.xz 1952372 SHA256 9a5fa5ecad5ac74e8e125bbd201e15e03c794df4cf4a662eab53eaa3523dfc58 SHA512 3fa550c49c35d53c220d1f7a3f3d49d5130e3dd4af657e05627782abb84a449c6632a9919f5a97c78a5b9d92137e8d4bd68d8b880cd86203f866b85b9cda3db3 WHIRLPOOL a7e8333211199d5bd3d6c72f5a561ec67e443036039b1dfe99309c79cf9fc2f23bb419a7a5da59b7ddb24f2edeece28195bf225d61282380d4eee9ff6c90bfdb
DIST gnome-terminal-3.23.90.tar.xz 1924436 SHA256 3da921a4d21dd1bc61cb2501a66701b2440bb667f7ff8697a88632685594c29a SHA512 f91c416b24360913b50d234d7f680e6e3e37f25d178fc53ac057bbeafc7cb867cc30f5f303d09b60d9a18cc090dbea2afcc4d2d05bcc4484c29f26993f735e04 WHIRLPOOL 7c6f72be05cdb89883a6fc6092495a2778371cfd26636904e9e5f1b8b170bcbfd5bfa63c8f160b65b6e34556e4ff12b5af580a316350e491273a6f37f969103a
+DIST gnome-terminal-3.24.2.tar.xz 1960952 SHA256 281edac30a07ca45beaaaf0a13fe2219cf8b87ece5e55dccbfc49ef769dfec0f SHA512 08cd7b1b08cf22618554b1a051dcfee4a967165bfe93b77a6bc8b0c935695101e773e8d53a482d71aadb9ba7be7ac991d82dbf53b7a6f74f1f5144e4158f8a93 WHIRLPOOL e3f7b6528edc8f257d1c43abc1ee07b8ae1c8c1dfb1e2ae0dae727ba5c3f7f90c06df92eb84b37ef6f52b6338b732e7e3af14729a9ddad887cce64142e784911
+DIST gnome-terminal-notify-open-title-transparency.patch.xz 37448 SHA256 7b83879f7035be77528b68328fed18018ae459792f7f22fae5e3d8b631d7e2cf SHA512 9af0d56df105a5bdb81b2609794669557a7f442f71b240ee10a6411fab20ad74c14489dbb9a536e208515053ea17776b3a15afb3b949a75a66f8c2ab3dbbff96 WHIRLPOOL 2059fc03a98a76b1f15e9adc7d0002daf3d337960d5d90dac9ae5d551762c18fcbc9530b32afa02edf0e5bd58140267bffbf99c9d50268338784428fe5244329
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.24.2.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.24.2.ebuild
new file mode 100644
index 000000000000..486db9e85068
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.24.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~leio/distfiles/gnome-terminal-notify-open-title-transparency.patch.xz )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control
+# Needed vte in 3.24.2 is 0.48.2, but we add desktop notification patches in 0.48.3 that non-vanilla needs
+RDEPEND="
+ >=dev-libs/glib-2.42:2[dbus]
+ >=x11-libs/gtk+-3.20:3[X]
+ >=x11-libs/vte-0.48.3:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/dconf-0.14
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-3 )
+"
+# itstool/yelp-tools required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-${SLOT}.sh"
+
+src_prepare() {
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore separate menuitems for opening tabs and windows
+ # Restore "Set title" support
+ # http://pkgs.fedoraproject.org/cgit/rpms/gnome-terminal.git/plain/gnome-terminal-notify-open-title-transparency.patch
+ # Depends on vte[-vanilla] for OSC 777 patch in VTE
+ eapply "${WORKDIR}"/${PN}-notify-open-title-transparency.patch
+ fi
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-migration \
+ $(use_enable debug) \
+ $(use_enable gnome-shell search-provider) \
+ $(use_with nautilus nautilus-extension) \
+ VALAC=$(type -P true)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS"
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}