summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/gnome-terminal')
-rw-r--r--x11-terms/gnome-terminal/Manifest1
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.22.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index 45e63c581179..c5d29377efcc 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -1,2 +1,3 @@
DIST gnome-terminal-3.20.2.tar.xz 1897148 SHA256 f5383060730f1de70af35e917f82d5b6a14d963ad9cfd6a0e705f90011645a23 SHA512 fe56d5a72580830232880b8e1752b5b268cf559ec9c031382b3631af4b9f2f1b7f661cc22df2643e0d50e66f8595a625e000f6068b16b8c5c9b6e9256a1db79a WHIRLPOOL 4909f016d75ff74705b6d3c92f1f7f3dbfad09ed6172895b1ca3eb455940c57c181a001907cccf78997e49509eb0dd90c7a640e2a3aeeff662ca1fee207f80d1
DIST gnome-terminal-3.22.0.tar.xz 1931164 SHA256 97e6b1b4128ac133d8917b3940c71ddf9b89d189c5ac8402b1060126733993ed SHA512 71cdac0cec2fdcb43519aad6067c009a122e187fb4bf146cea90a3146338fd3b443aa27a7110c2a66324aa2239fe1c5e3326ad312be840369dbea066a2a2c93a WHIRLPOOL 5d4f95141230facf07870fce6b0a5d564b38b25555ef6f1f84b19ea480a4947db1f670bb844d271bfd0bdb329a255b71cddd60f8e64eec2f899452b3e2b3ff27
+DIST gnome-terminal-3.22.1.tar.xz 1944832 SHA256 b00752336eb22d6d9f10c863c166ac73dcbb2ce4b280abdc0c78337e261bb0d4 SHA512 f6ebfa579de1e0f33d77dce75dfcd6ba47fbc0a508448eb16a15267988aa35acf3dd8bdfd55d32c00dcee9f79d4308b998c17500cf7c872ff928ce84e87a730a WHIRLPOOL 359adbdf464a57dcf8c19eab5e8aa0379a373fbbe8376e8e25c8fab9b4953645ebb9b54f40b8617f6542dd72c568c74dcb32a6facb39577df5647bc7c700e7bf
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.22.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.22.1.ebuild
new file mode 100644
index 000000000000..9316ccba9afa
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.22.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2 readme.gentoo-r1
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control
+RDEPEND="
+ >=dev-libs/glib-2.42:2[dbus]
+ >=x11-libs/gtk+-3.20:3[X]
+ >=x11-libs/vte-0.46.1:2.91
+ >=dev-libs/libpcre2-10
+ >=gnome-base/dconf-0.14
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-3 )
+"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened
+ tab you will need to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte.sh"
+
+src_prepare() {
+ if ! use vanilla; then
+ # OpenSuSE patches, https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # http://pkgs.fedoraproject.org/cgit/rpms/gnome-terminal.git/tree/gnome-terminal-transparency-notify.patch (first 3 parts)
+ eapply "${FILESDIR}"/${PN}-3.22.0-transparency.patch
+ eautoreconf
+ fi
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-migration \
+ $(use_enable debug) \
+ $(use_enable gnome-shell search-provider) \
+ $(use_with nautilus nautilus-extension) \
+ VALAC=$(type -P true)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS"
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}