summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/qterminal/qterminal-0.9.0.ebuild')
-rw-r--r--x11-terms/qterminal/qterminal-0.9.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-terms/qterminal/qterminal-0.9.0.ebuild b/x11-terms/qterminal/qterminal-0.9.0.ebuild
new file mode 100644
index 000000000000..6b2342fe6296
--- /dev/null
+++ b/x11-terms/qterminal/qterminal-0.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver gnome2-utils xdg-utils
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://lxqt.org/"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ =x11-libs/qtermwidget-$(ver_cut 1-2)*:*
+"
+DEPEND="${RDEPEND}
+ >=dev-util/lxqt-build-tools-0.5.0
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}