summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/arc-theme/Manifest1
-rw-r--r--x11-themes/arc-theme/arc-theme-20170302.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index 59d3790cfdb1..37efddc02690 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -1 +1,2 @@
DIST arc-theme-20161119.tar.gz 1534183 SHA256 a470ab33b1ad2b4ba280e61f0e1c4f8d4973ceccc84dc2db1e37fae66b5770cd SHA512 996d8583c4de654dc5979703c85ad3a0eeebef435a264df1b2c8044b9e62f4f74561294a16c5ebf9a213ec5ff7c23f94a360a76502321836bbb83b7396765da0 WHIRLPOOL def6901b2d918afaa95e5630420cb0c65fedb343d49c8900440f6fb888a23b2befd6a47f6802d6012c0dd359edc56ba9a6b75f7f0d6960b97da4f95c489ecc40
+DIST arc-theme-20170302.tar.gz 1534152 SHA256 9ca5c1d1ac267c4ae3725e84519d42bfb8c4c6934989839ebe3cb8699fbdfd45 SHA512 99408a7c4db2bd2d81453e308ae5d9bc9bfda4f11e57191936f985de2937debff76c4d1f37a97ac8f5ad3751401ee8ad02457e4558b9c4aedc2bfeba1736ef03 WHIRLPOOL e8f230dec707333a77e4b58ea1cf91e72bd1d3528116598278a309298388a535b2a4984151aafa2e7aa6d1a5d32fd2b7807f50eb7c15640a30201c9887ff20ab
diff --git a/x11-themes/arc-theme/arc-theme-20170302.ebuild b/x11-themes/arc-theme/arc-theme-20170302.ebuild
new file mode 100644
index 000000000000..d604f1551227
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20170302.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A flat theme with transparent elements for GTK+3, GTK+2 and GNOME Shell"
+HOMEPAGE="https://github.com/horst3180/arc-theme"
+SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 mate xfce"
+
+# Supports various GTK+3 versions and uses pkg-config to determine which
+# set of files to install. Updates will break it but only this fix will
+# help. https://github.com/horst3180/arc-theme/pull/436
+DEPEND="gtk3? ( >=x11-libs/gtk+-3.14:3
+ virtual/pkgconfig )"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="gtk2? ( x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-unity \
+ $(use_enable cinnamon) \
+ $(use_enable gtk2) \
+ $(use_enable gtk3) \
+ $(use_enable gnome-shell) \
+ $(use_enable mate metacity) \
+ $(use_enable xfce xfwm)
+}