summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/Manifest1
-rw-r--r--xfce-base/xfwm4/xfwm4-4.13.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index 717be075ce7a..78ad5e1c1a35 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -1,2 +1,3 @@
DIST xfwm4-4.12.3.tar.bz2 1191929 SHA256 f4a988fbc4e0df7e8583c781d271559e56fd28696092f94ae052e9e6edb09eac SHA512 96fcc76fc640027883a7a3373836565987b1d3d4e61fb40aa7e2f990a8140d92cf66171fb4517368faba45c9083a3ad19f589d59b07a55c3417aaaca87e408d7 WHIRLPOOL 0fd8e058694cb2f6486bc59443e00d8ed42ebd9dabe39775451d94c14c7e2ea87a520edea26e3bc7033fa1d95aa0ca1a6b2045eca9a1c9d8ecfb67f1ef88b0a8
DIST xfwm4-4.12.4.tar.bz2 1208874 SHA256 fa74048a75649a6e92df763a3cfb706d3fed1e1a6adf567f6693325a5a6efb36 SHA512 a33530b08f094456c45ad7c627ba34d3772eaeacdc9f422a3a54a16194d494cb1d6798122398d917fb8bc970db7e1184d9dc8edefc365dacc86de22be397b43d WHIRLPOOL fa26fd4bf758b7c57964956809e9036320aaecc43fad2a0aa3fdca2bd83dda7edc1884fa86ed7f1ab12b94066f4bc729d5aa4e001121f813f128ebb4cc3c3018
+DIST xfwm4-4.13.0.tar.bz2 1229878 SHA256 7f284c9734f565d8298cac9b67ede252a56c7d67c44531f8c2c07abe5ef0f365 SHA512 01c6cc31dc179ccb51f9881f64ee9e4e16320ab888381d0b203ca0b2a46097048c30eabe7083aaec869c80e8e358c287896d6a1965a36ed6f2f981c27cfb2dce WHIRLPOOL 80a283c10c8cd047edeb8aef79f83236b4793a2929c48f01bc72be422c6c0bd389f1b9830375247847ec4bda39f126b36e5e6eccbfd8d32dd72fb5a02f4c0c87
diff --git a/xfce-base/xfwm4/xfwm4-4.13.0.ebuild b/xfce-base/xfwm4/xfwm4-4.13.0.ebuild
new file mode 100644
index 000000000000..2d7df4d0a985
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.13.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite"
+
+RDEPEND="dev-libs/dbus-glib:=
+ >=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-2.24:2=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/pango:=
+ >=x11-libs/libwnck-2.30:1=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.11:=
+ >=xfce-base/xfconf-4.10:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification:= )
+ xcomposite? (
+ x11-libs/libXcomposite:=
+ x11-libs/libXdamage:=
+ x11-libs/libXfixes:=
+ )"
+# libICE/libSM: not really used anywhere but checked by configure
+# https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ x11-libs/libICE
+ x11-libs/libSM
+ xfce-base/exo
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ # not packaged atm, bug #549040
+ --disable-xpresent
+ $(use_enable xcomposite compositor)
+ )
+
+ econf "${myconf[@]}"
+}