summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* kde-misc/wacomtablet: amd64 stable wrt bug #642458Mikle Kolyada2018-01-041-2/+2
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* x11-libs/wxGTK: Apply patchset for lots of 3.0 branch fixes and webkit-gtk:4 ↵Mart Raudsepp2018-01-044-2/+82
| | | | | | | | | | | | | | | | | | | | | | | | | port Includes 105 patches taken from WX_3_0_BRANCH, plus one from master only that we need to not litter DT_NEEDED with wxWebView library without --as-needed (it was part of squashed wxGTK-3.0.2.0-webview-fixes.patch before). Also includes my patch to install wx/evtloopsrc.h in core-only builds. Most notably the patchset adds support for webkit2gtk API (as provided by security safe net-libs/webkit-gtk:4), and lots of gtk3 port fixes, hopefully making 3.0-gtk3 SLOT good enough for mass transition without problematic runtime regressions. The patchset touches lines right above the first Makefile.in changes in the collision patch, so that patch needed to be adjusted to not fail on top of the patchset. Ideally the collision patch would be revised and moved to the same approach as 3.0-gtk3 has with seds - or vice-versa, but at least same approach.. Compiling amule[-X] and veracrypt[-X] against wxGTK[-X] is untested; please test and close the relevant bugs (617440 and 605018) if this is fixed now. Bug: https://bugs.gentoo.org/629122 Bug: https://bugs.gentoo.org/617440 Bug: https://bugs.gentoo.org/605018 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-libs/wxGTK: remove USE=webkit (wxWebView) support from gtk2 based SLOT=3.0Mart Raudsepp2018-01-041-3/+2
| | | | | | | | | | gtk2 supporting webkit-gtk versions have not received security fixes for years, so don't allow subjecting oneself to such an unsafe possibility. The only in-tree wxGTK:3.0[webkit] consumer was ported to wxGTK:3.0-gtk3[webkit], which will have a security safe version in a subsequent commit. Bug: https://bugs.gentoo.org/629122 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-libs/wxGTK: fix translation installation and usage for SLOT=3.0-gtk3Mart Raudsepp2018-01-042-2/+19
| | | | | | | | Properly sed the .mo versioning and patch wxTranslations::AddStdCatalog to use the slotted translation domain. Closes: https://bugs.gentoo.org/618624 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-libs/wxGTK: don't eautoreconf or rename configure.in filesMart Raudsepp2018-01-041-7/+1
| | | | | | | | | | | | | | | | | | wxWidgets doesn't use full autotools (at least not automake), and it maintains an autoconf'ed configure script inside its code repository, which gets (usually) updated after each configure.in update. Because we don't eautoreconf to see a slightly dumb warning about configure.in vs configure.ac, remove the renaming, as the code is buggy and breaks on some non-default PORTAGE_TMPDIR values. I don't intend to ever add back an eautoreconf if at all possible, but if it is, make sure such renaming isn't buggy like this. Also note that other Makefile.in's seem to refer to the preset configure.in's by name (with .in ending), so renaming them is probably wrong as well via such a global "find" approach, at least without patching the references too. The eautoreconf and buggy renaming was already removed on bump for 3.0 SLOT. Closes: https://bugs.gentoo.org/614982 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-libs/wxGTK: Fix versionating variables for current case of no subrelease ↵Mart Raudsepp2018-01-041-2/+2
| | | | | | | | | | number This is a bug of my own doing, not from kuzetsa, as I edited the commit myself to bump to 3.0.3 instead of 3.0.3.1, latter of which has a subrelease number and all was well then. Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-libs/wxGTK: Port to EAPI-6Mart Raudsepp2018-01-042-20/+14
| | | | | | | | SLOT=3.0 only, 3.0-gtk3 already was, so this is done based on that to also reduce delta. Also removes some extra whitespaces that don't seem to give any indent value to me (though some are kept, that do line things up a bit better). Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-libs/wxGTK: Remove redundant commentMart Raudsepp2018-01-042-8/+2
| | | | | | | We don't use wxPython tarballs anymore, as wxPython is focusing on their Phoenix project (wxPython4) and not releasing these neat tarballs anymore. Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-libs/wxGTK: bump to v3.0.3, using gstreamer slot 1.0kuzetsa2018-01-043-0/+343
| | | | | Bug: https://bugs.gentoo.org/629208 Closes: https://bugs.gentoo.org/619830
* app-editors/kile: Drop oldMikle Kolyada2018-01-042-58/+0
| | | | | Closes: https://bugs.gentoo.org/642462 Package-Manager: Portage-2.3.13, Repoman-2.3.3
* app-editors/kile: amd64 stable wrt bug #642462Mikle Kolyada2018-01-041-2/+2
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* dev-util/strace: amd64 stable wrt bug #643014Mikle Kolyada2018-01-041-1/+1
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* app-crypt/gpgme: amd64 stable wrt bug #643196Mikle Kolyada2018-01-041-2/+2
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* app-eselect/eselect-php: amd64 stable wrt bug #642788Mikle Kolyada2018-01-041-2/+2
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* dev-libs/libpqxx: amd64 stable wrt bug #641128Mikle Kolyada2018-01-041-2/+2
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* sci-libs/geos: amd64 stable wrt bug #641136Mikle Kolyada2018-01-041-2/+2
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* net-libs/axtls: amd64 stable wrt bug #630760Mikle Kolyada2018-01-041-2/+2
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* sys-devel/binutils-apple: set forgotten CTARGET in 3.2Fabian Groffen2018-01-041-1/+9
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* dev-python/stapler: inherit vcs-snapshot eclass.Patrice Clement2018-01-041-3/+1
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* app-vim/vim2hs: inherit vcs-snapshot eclass.Patrice Clement2018-01-041-4/+2
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* sys-firmware/intel-microcode: Rev bump for CVE-2017-5715 mitigationThomas Deutschmann2018-01-042-0/+40
| | | | | | | | | | | The CPU microcode for Intel Haswell-X, Skylake-X and Broadwell-X chipsets was updated to report both branch prediction control via CPUID flag and ability to control branch prediction via an MSR register. Required for kernel mitigation against CVE-2017-5715. Bug: https://bugs.gentoo.org/643430 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sys-block/tw_cli: special version for >=3.8 kernelRobin H. Johnson2018-01-042-10/+125
| | | | | | | | | | | | | | | | | | | | | | | | TL;DR: if you run 3ware cards on a 3.8 or newer kernel, you need to upgrade the utility to correctly write card variables, as the old version will sometimes segfault. Tested on hardware models: 9750-4i, 9650SE-8LPML, 9690SA. Per email: > I've noticed recently that sys-block/tw_cli will segfault on modern > systems when setting variables on a card (at least on a 9750-4i). > ... > when you go to run a battery capacity test, it'll complete the capacity > test command, but segfault before it can update the timestamp on the > card to record the last capacity test date. That causes the date to > become "01-Jan-1970", and then dmesg will get flooded with "Battery > capacity test overdue" messages. That's what prompted me to open a case > with Broadcom, and then try to find some kind of workaround. Reported-by: Joshua Kinard <kumba@gentoo.org> Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: Portage-2.3.16, Repoman-2.3.6 RepoMan-Options: --force
* sys-kernel/gentoo-sources: genpatches-4.14-16Alice Ferrazzi2018-01-042-0/+31
| | | | | | contains the combined urgent patch for x86 page table isolation fixes Package-Manager: Portage-2.3.13, Repoman-2.3.3
* profiles: mask gentoo-sources-4.14.x that are affected by x86 intel ↵Alice Ferrazzi2018-01-041-0/+13
| | | | processor flaw
* mail-client/thunderbird: bump to 52.5.2 to fix the mailsploit vulnIan Stakenvicius2018-01-042-0/+399
| | | | | | | | This bump includes the fix for the "mailsploit" vulnerability, as well as others that may or may not affect linux systems. More info can be found at https://www.mozilla.org/en-US/thunderbird/52.5.2/releasenotes/ Package-Manager: Portage-2.3.13, Repoman-2.3.3
* media-tv/dvbtune: Fix-in-place missing implicit include from kernelChris Reffett2018-01-042-1/+12
| | | | | | | 4.13. No bump since it's only a build failure. Closes: https://bugs.gentoo.org/578180 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sci-visualization/gle: fix removing Qt4 guiAndrey Grozin2018-01-041-1/+2
| | | | | Closes: https://bugs.gentoo.org/642562 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sci-visualization/veusz: bump to 2.1.1Andrey Grozin2018-01-042-0/+80
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sys-apps/keyutils: Version 1.5.9-r4 stable for x86.Lars Wendler2018-01-041-1/+1
| | | | | Bug: https://bugs.gentoo.org/643406 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* www-client/opera: Old.Jeroen Roovers2018-01-042-110/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* www-client/opera: Version 50.0.2762.45.Jeroen Roovers2018-01-042-0/+110
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* www-client/opera-beta: Old.Jeroen Roovers2018-01-042-115/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sys-apps/keyutils: Version 1.5.9-r4 stable for amd64.Lars Wendler2018-01-041-2/+2
| | | | | Bug: https://bugs.gentoo.org/643406 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* net-libs/gsoap: Bump to version 2.8.59Lars Wendler2018-01-042-0/+84
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* eclass/multilib-build: fix ABI matching for ppc-macosFabian Groffen2018-01-041-2/+2
| | | | | | On Darwin, gcc emits __ppc__ or __ppc64__, not __powerpc__. Do additionally allow the short variants to match, such that we can use the wrapped packages on ppc-macos as well.
* dev-python/stapler: new ebuild.Patrice Clement2018-01-043-0/+41
| | | | | | | | | | | | stapler is a suite of tools for PDF files manipulation. It makes use of the PyPDF2 library to provide a (somewhat) lighter alternative to pdftk. See https://github.com/hellerbarde/stapler. Bug: https://bugs.gentoo.org/562568 Package-Manager: Portage-2.3.13, Repoman-2.3.3 Reviewed-by: James Le Cuirot <chewi@gentoo.org>
* mail-client/thunderbird: cleanup oldIan Stakenvicius2018-01-044-1263/+0
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* x11-terms/aterm: Move hppa to unstableLars Wendler2018-01-041-2/+2
| | | | | | as there's no stable afterstep package for hppa anymore. Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-wm/afterstep: Added sys-libs/readline to RDEPEND.Lars Wendler2018-01-041-14/+19
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* x11-wm/afterstep: Removed old.Lars Wendler2018-01-047-261/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sys-kernel/gentoo-sources: genpatches-4.14-15Alice Ferrazzi2018-01-042-0/+31
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* sys-kernel/linux-firmware: Remove oldManuel Rüger2018-01-043-228/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sys-kernel/linux-firmware: Update snapshotManuel Rüger2018-01-042-0/+115
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sys-devel/bc: Added missing virtual/yacc dependency.Lars Wendler2018-01-042-21/+28
| | | | | Closes: https://bugs.gentoo.org/593924 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* net-libs/nodejs: EAPI=6.Jeroen Roovers2018-01-042-4/+4
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* net-libs/nodejs: Obsolete.Jeroen Roovers2018-01-042-200/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* net-libs/nodejs: Version 0.12.18.Jeroen Roovers2018-01-042-0/+125
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sys-apps/yarn: Version bump to 1.3.2Manuel Rüger2018-01-042-0/+32
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* net-libs/nodejs: Old.Jeroen Roovers2018-01-044-608/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* net-libs/nodejs: Version 4.8.7 6.12.3 8.9.4.Jeroen Roovers2018-01-044-0/+547
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6