summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-crypt/qca: Stabilize 2.3.4 amd64, #818289Sam James2 days1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-crypt/qca: Stabilize 2.3.4 x86, #818289Sam James2 days1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-crypt/qca: 2.3.4 version bumpAndreas Sturmlechner2021-09-152-0/+83
| | | | | | Closes: https://bugs.gentoo.org/805227 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-crypt/qca: keyword ~riscvYixun Lan2021-08-261-1/+1
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
* app-crypt/qca: add lower bound on qtcoreSam James2021-08-251-1/+1
| | | | | | | | | | | This won't help many people but for some folks upgrading older installs, it will hopefully be a useful nudge. Gentoo dropped 5.12.x in March 2020, so not _too_ long ago, I suppose. Signed-off-by: Sam James <sam@gentoo.org>
* */*: Add more kde.org upstream metadataAndreas Sturmlechner2021-08-211-18/+21
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Drop 2.3.2Andreas Sturmlechner2021-08-094-178/+0
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Stabilize 2.3.3 arm64, #800175Sam James2021-08-061-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-crypt/qca: amd64 stable wrt bug #800175Agostino Sarubbo2021-07-171-1/+1
| | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.2 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-crypt/qca: x86 stable wrt bug #800175Agostino Sarubbo2021-07-151-1/+1
| | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.2 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-crypt/qca: 2.3.3 version bumpAndreas Sturmlechner2021-06-102-0/+83
| | | | | Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Drop 2.3.1Andreas Sturmlechner2021-04-073-118/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Stabilize 2.3.2 arm64, #774219Mikle Kolyada2021-04-061-1/+1
| | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* app-crypt/qca: amd64 stable wrt bug #774219Agostino Sarubbo2021-04-061-1/+1
| | | | | | Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-crypt/qca: x86 stable (bug #774219)Thomas Deutschmann2021-04-061-1/+1
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* app-crypt/qca: Fix CryptographicMessageSyntaxAndreas Sturmlechner2021-03-053-1/+94
| | | | | | Closes: https://bugs.gentoo.org/766932 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: 2.3.2 version bumpAndreas Sturmlechner2021-02-052-0/+85
| | | | | Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Fix build with GCC-11Andreas Sturmlechner2021-01-242-2/+35
| | | | | | Closes: https://bugs.gentoo.org/764047 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Drop 2.3.0Andreas Sturmlechner2020-09-062-85/+0
| | | | | Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: arm64 stable (bug #731966)Sam James2020-08-031-1/+1
| | | | | Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
* app-crypt/qca: x86 stable wrt bug #731966Agostino Sarubbo2020-07-301-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-crypt/qca: amd64 stable wrt bug #731966Agostino Sarubbo2020-07-301-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-crypt/qca: 2.3.1 version bumpAndreas Sturmlechner2020-07-062-0/+85
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Drop 2.2.1Andreas Sturmlechner2020-03-192-85/+0
| | | | | Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: arm64 stable (bug #712776)Mart Raudsepp2020-03-191-1/+1
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* app-crypt/qca: x86 stable wrt bug #712776Agostino Sarubbo2020-03-181-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-crypt/qca: amd64 stable wrt bug #712776Agostino Sarubbo2020-03-171-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-crypt/qca: Drop 2.2.90Andreas Sturmlechner2020-02-262-85/+0
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: 2.3.0 version bumpAndreas Sturmlechner2020-02-252-0/+85
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: 2.2.90 version bump, no KEYWORDSAndreas Sturmlechner2020-02-132-0/+85
| | | | | Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Drop USE libresslAndreas Sturmlechner2020-02-111-8/+4
| | | | | | | | Let's not pretend like it works with any libressl version in tree. Bug: https://bugs.gentoo.org/709288 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* */*: reassign crypto@ packagesMikle Kolyada2020-01-081-4/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* */*: Switch kde proj packages to cmake.eclassAndreas Sturmlechner2019-12-291-4/+4
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Drop 2.2.0Andreas Sturmlechner2019-12-222-89/+0
| | | | | Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Rollover stable keywords from 2.2.0Andreas Sturmlechner2019-12-221-1/+1
| | | | | | | No code changes from .0, no reason to employ arch teams. Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* */*: [QA] Fix trivial cases of MissingTestRestrictMichał Górny2019-12-112-0/+2
| | | | | | | | | | | | | | | | | | The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-crypt: Remove *-fbsd KEYWORDSMichał Górny2019-10-112-2/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-crypt/qca: arm64 stableAaron Bauman2019-05-271-1/+1
| | | | | | Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.12 RepoMan-Options: --include-arches="arm64"
* app-crypt/qca: Drop 2.1.3-r2Andreas Sturmlechner2019-05-154-232/+0
| | | | | Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: x86 stable wrt bug #679680Mikle Kolyada2019-05-111-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="x86"
* app-crypt/qca: 2.2.1 version bumpAndreas Sturmlechner2019-04-272-0/+88
| | | | | Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: amd64 stable wrt bug #679680Mikle Kolyada2019-04-231-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
* app-crypt/qca: Drop 2.2.0_pre20180606 snapshotAndreas Sturmlechner2019-04-102-88/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: 2.2.0 version bumpAndreas Sturmlechner2019-04-092-0/+88
| | | | | | Bug: https://bugs.gentoo.org/679680 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
* app-crypt/qca: EAPI-7 bumpAndreas Sturmlechner2019-02-241-3/+5
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-crypt/qca: Add 2.2.0_pre20180606 snapshotAndreas Sturmlechner2018-06-092-0/+86
| | | | | | | botan-2 and openssl-1.1 support. Closes: https://bugs.gentoo.org/592526 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* app-crypt/qca: Actually fix depsAndreas Sturmlechner2018-06-062-0/+39
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* app-crypt/qca: DEPENDs were fixed upstreamAndreas Sturmlechner2018-06-061-2/+4
| | | | | | Upstream commit e854f357f4037e2c8c781ebd04ec5164a882b9b3 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* app-crypt/qca: Drop old Qt4-basedAndreas Sturmlechner2018-05-261-122/+0
| | | | | | | Dropping arches without remaining revdeps. Bug: https://bugs.gentoo.org/627178 Package-Manager: Portage-2.3.38, Repoman-2.3.9