summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-editors/joe: arm stable, bug #605872Markus Meier2017-02-181-1/+1
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="arm"
* app-editors/nano: add upstream fix for USE=minimal build #591026Mike Frysinger2017-02-182-0/+98
|
* app-editors/emacs: Fix temacs segmentation fault due to endless calloc loop.Ulrich Müller2017-02-182-2/+2
| | | | | | Bug: 609680 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/wily: Fix toolong.DESCRIPTIONHarri Nieminen2017-02-171-2/+2
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3996
* app-editors/lfhex: Fix toolong.DESCRIPTIONHarri Nieminen2017-02-171-2/+2
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3996
* app-editors/jove: Fix toolong.DESCRIPTIONHarri Nieminen2017-02-171-2/+2
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3996
* app-editors/nvi: sparc stable wrt bug #609482Agostino Sarubbo2017-02-171-1/+1
| | | | | | Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="sparc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-editors/nvi: x86 stable wrt bug #609482Agostino Sarubbo2017-02-161-1/+1
| | | | | | Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-editors/nvi: amd64 stable wrt bug #609482Agostino Sarubbo2017-02-161-2/+2
| | | | | | Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-editors/ghex: remove oldMart Raudsepp2017-02-152-27/+0
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/neovim: Update libtermkey dependency requirementOle Reifschneider2017-02-121-2/+2
| | | | Package-Manager: portage-2.3.3
* app-editors/kile: Depend on virtual/imagemagick-toolsDavid Seifert2017-02-111-8/+3
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
* app-editors/ghex: x86 stable, bug 606818Pacho Ramos2017-02-111-1/+1
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="x86"
* app-editors/ghex: amd64 stable, bug 606818Pacho Ramos2017-02-111-1/+1
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64"
* app-editors/emacs-vcs: Do not depend on sys-apps/paxctl.Ulrich Müller2017-02-103-12/+3
| | | | | | Bug: 607990 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs: Do not depend on sys-apps/paxctl.Ulrich Müller2017-02-105-20/+5
| | | | | | Bug: 607990 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs-vcs: Add systemd and threads USE flags.Ulrich Müller2017-02-102-1/+5
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs-vcs: Add dynamic-loading USE flag.Ulrich Müller2017-02-104-3/+8
| | | | | | | | | This will enable loading of dynamic libraries at runtime. Based on patch submitted by Steven Cordwell <steven.cordwell@uqconnect.edu.au>. Bug: 608382 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs: Add dynamic-loading USE flag.Ulrich Müller2017-02-103-2/+6
| | | | | | | | | This will enable loading of dynamic libraries at runtime. Based on patch submitted by Steven Cordwell <steven.cordwell@uqconnect.edu.au>. Bug: 608382 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/atom: Add dependency on x11-libs/libxkbfile.Elvis Pranskevichus2017-02-082-1/+2
| | | | | | | | | The keyboard-layout module needs this. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=608478 Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3761
* app-editors/atom: Version bump to 1.12.7, 1.13.1Elvis Pranskevichus2017-02-085-4/+442
| | | | | Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3761
* app-editors/joe: version bump 4.4 bug #606930Amy Liffey2017-02-052-0/+48
| | | | Package-Manager: portage-2.3.0
* app-editors/emacs-vcs: Cleanup libdir to avoid future slot collisions.Ulrich Müller2017-02-041-0/+1
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs-vcs: Temporarily block against Emacs 25.2.Ulrich Müller2017-02-041-0/+3
| | | | | | ... and its release candidates, too. Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs-vcs: Update dependency on net-libs/webkit-gtk.Ulrich Müller2017-02-041-1/+1
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs: First release candidate for Emacs 25.2.Ulrich Müller2017-02-042-0/+359
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs: Add slot operator for ncurses.Ulrich Müller2017-02-045-8/+8
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs-vcs: Add slot operator for ncurses.Ulrich Müller2017-02-043-3/+3
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/emacs-vcs: Upstream change of emacs-25 version number.Ulrich Müller2017-02-041-1/+1
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/kile: allow any Okular and evince as PDF viewerMaciej Mrozowski2017-02-031-2/+6
|
* app-editors/mg: Stable for HPPA (bug #606116).Jeroen Roovers2017-02-031-1/+1
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --ignore-arches
* app-editors/nano: Stable for HPPA (bug #606792).Jeroen Roovers2017-01-311-1/+1
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --ignore-arches
* app-editors/emacs-vcs: Use bash -c rather than subshell.Ulrich Müller2017-01-311-1/+1
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-editors/zile: dropped ~x86-freebsdFabian Groffen2017-01-292-4/+4
| | | | Package-Manager: portage-2.3.3
* app-editors/vim: dropped ~hppa-hpux ~ia64-hpux ~x64-freebsd ~x86-freebsd ↵Fabian Groffen2017-01-292-3/+3
| | | | | | ~x86-interix Package-Manager: portage-2.3.3
* app-editors/vim-core: dropped ~hppa-hpux ~ia64-hpux ~x64-freebsd ↵Fabian Groffen2017-01-296-11/+11
| | | | | | ~x86-freebsd ~x86-interix Package-Manager: portage-2.3.3
* app-editors/vile: dropped ~x86-interixFabian Groffen2017-01-295-10/+10
| | | | Package-Manager: portage-2.3.3
* app-editors/shed: dropped ~x86-interixFabian Groffen2017-01-291-2/+2
| | | | Package-Manager: portage-2.3.3
* app-editors/scite: dropped ~x86-freebsdFabian Groffen2017-01-294-8/+8
| | | | Package-Manager: portage-2.3.3
* app-editors/ne: dropped ~x86-interixFabian Groffen2017-01-292-4/+4
| | | | Package-Manager: portage-2.3.3
* app-editors/nano: dropped ~hppa-hpux ~ia64-hpux ~ia64-linux ~x64-freebsd ↵Fabian Groffen2017-01-294-5/+5
| | | | | | ~x86-freebsd ~x86-interix Package-Manager: portage-2.3.3
* app-editors/mp: dropped ~x86-interixFabian Groffen2017-01-291-2/+2
| | | | Package-Manager: portage-2.3.3
* app-editors/leafpad: dropped ~x86-interixFabian Groffen2017-01-291-2/+2
| | | | Package-Manager: portage-2.3.3
* app-editors/joe: dropped ~x86-interixFabian Groffen2017-01-292-3/+3
| | | | Package-Manager: portage-2.3.3
* app-editors/hexedit: dropped ~x86-interixFabian Groffen2017-01-291-2/+2
| | | | Package-Manager: portage-2.3.3
* app-editors/hexcurse: dropped ~x86-interixFabian Groffen2017-01-291-2/+2
| | | | Package-Manager: portage-2.3.3
* app-editors/gvim: dropped ~x86-interixFabian Groffen2017-01-292-3/+3
| | | | Package-Manager: portage-2.3.3
* app-editors/ghex: dropped ~x86-interixFabian Groffen2017-01-292-4/+4
| | | | Package-Manager: portage-2.3.3
* app-editors/gedit: dropped ~ia64-linux ~x86-freebsd ~x86-interixFabian Groffen2017-01-292-4/+4
| | | | Package-Manager: portage-2.3.3
* app-editors/fte: dropped ~x86-interixFabian Groffen2017-01-292-4/+4
| | | | Package-Manager: portage-2.3.3