summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* media-tv/dvbtune: Fix-in-place missing implicit include from kernelChris Reffett2018-01-042-1/+12
| | | | | | | 4.13. No bump since it's only a build failure. Closes: https://bugs.gentoo.org/578180 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/mythtv: Drop oldPacho Ramos2017-12-311-359/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/mythtv: It doesn't really need media-libs/libdvb for dvb support ↵Pacho Ramos2017-12-312-2/+369
| | | | | | (#642606), bump eapi, don't show elog messages always, stop pre-stripping files. Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/mythtv: Disable optional requirement on libdvb (#451792)Pacho Ramos2017-12-272-9/+2
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/mythtv: Drop oldPacho Ramos2017-12-271-363/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/mythtv: x11-libs/libva is slottedCraig Andrews2017-12-181-0/+363
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/kodi: x11-libs/libva is slotted so include a slot operatorCraig Andrews2017-12-182-1/+297
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/tvheadend: libdvben50221 is now effectively bundledJames Le Cuirot2017-12-171-5/+3
| | | | | | | | | | The dependency on the no-longer-maintained linuxtv-dvb-apps can now be dropped. How ironic when I did the first bump in years just a few weeks ago. With this dependency gone, we may as well enable DDCI by default. Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/tvheadend: add ddci USE flag (support for DDCI hardware)Daniel Scheller2017-12-172-2/+7
| | | | | | | | | | | --enable-ddci enables the recently added support for the Digital Devices CI hardware (Octopus CI, DuoFlex CI), for which the driver exposes their functionality via a /dev/dvb/adapterX/secY (recent kernels) or ciY (dddvb vendor driver package, both supported equally) dev node. This support will be part of the tvheadend 4.4 release. Repoman 2.3.3 (portage-2.3.13) Closes: https://github.com/gentoo/gentoo/pull/6399
* media-tv/kodi: drop dependency on x11-libs/libva[egl]Craig Andrews2017-12-161-1/+1
| | | | | | Kodi doesn't require/use x11-libs/libva[egl] and libva 2.0 doesn't have the egl use flag. Package-Manager: Portage-2.3.19, Repoman-2.3.6
* media-tv/v4l-utils-1.10.1-r0: amd64 stableTobias Klausmann2017-12-161-1/+1
| | | | Gentoo-Bug: http://bugs.gentoo.org/631918
* media-tv/kodi: Require >=media-libs/libbluray-1.0.2Craig Andrews2017-12-161-1/+1
| | | | | | See https://github.com/xbmc/xbmc/pull/13149 Package-Manager: Portage-2.3.18, Repoman-2.3.6
* media-tv/kodi: Do not use media-fonts/notoCraig Andrews2017-12-151-13/+0
| | | | | | | | The "Noto" font used by Kodi is a modified version of Noto. See https://github.com/xbmc/xbmc/pull/12956 and https://github.com/xbmc/xbmc/pull/13060 Package-Manager: Portage-2.3.18, Repoman-2.3.6
* media-tv/kodi: linux code moved to xbmc/platform/linuxCraig Andrews2017-12-151-1/+1
| | | | | | See https://github.com/xbmc/xbmc/pull/13179 Package-Manager: Portage-2.3.18, Repoman-2.3.6
* media-tv/*: Update Manifest hashesMichał Górny2017-12-1020-84/+84
|
* media-tv/plex-media-server: version bumpJonathan Vasquez2017-12-082-2/+138
| | | | Package-Manager: Portage-2.3.14, Repoman-2.3.6
* media-tv/tvheadend: Add libressl support via USE flagJames Le Cuirot2017-12-052-4/+6
| | | | | Closes: https://bugs.gentoo.org/639940 Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/tvheadend: Drop old 4.0.9James Le Cuirot2017-12-044-147/+0
| | | | | | | Closes: https://bugs.gentoo.org/595032 Closes: https://bugs.gentoo.org/596930 Closes: https://bugs.gentoo.org/633966 Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/tvheadend: Version bump to 4.2.4 and 9999 updateJames Le Cuirot2017-12-048-34/+253
| | | | | | | | | | | | | | | | | | | * Add support for dvbcsa via USE flag * Add support for dvben50221 via USE flag * Drop support for libav (fails version checks, missing symbols) * Source DTV scan tables from new media-tv/dtv-scan-tables package * Set tvheadend user HOME to /etc/tvheadend to allow for XMLTV data * Tighten up the systemd service unit * Add debug USE flag for trace support * Fix inotify kernel config check * Add ffmpeg sub-dependencies and associated USE flags (9999 only) Closes: https://bugs.gentoo.org/579048 Closes: https://bugs.gentoo.org/579986 Closes: https://bugs.gentoo.org/586448 Closes: https://bugs.gentoo.org/588210 Closes: https://bugs.gentoo.org/626238 Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/xmltv: Version bump to 0.5.70James Le Cuirot2017-12-033-1/+198
| | | | | | | The grabber list has been updated according to the release notes. The sd_json grabber has been renamed to zz_sdjson. Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/linuxtv-dvb-apps: Newer snapshot, EAPI 6, cleanupJames Le Cuirot2017-12-032-1/+93
| | | | | | | | | | | | | As this is no longer maintained upstream, it had been suggested that this package be last-rited but there are still utilities and libraries that are not available elsewhere. libdvben50221 is still used by tvheadend, for example. Other distros still package this accordingly. The DTV scan tables are no longer included as they have been split out into a new project, hence the new dependency. Closes: https://bugs.gentoo.org/383993 Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/dtv-scan-tables: Add ~ppc and ~ppc64 keywordsJames Le Cuirot2017-12-032-2/+2
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/kodi: Depend on virtual/ttf-fonts instead of media-fonts/corefontsCraig Andrews2017-11-292-1/+297
| | | | | Closes: https://bugs.gentoo.org/609964 Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/v4l-utils: stable 1.10.1 for ppc, bug #631918Sergei Trofimovich2017-11-271-2/+2
| | | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6 RepoMan-Options: --include-arches="ppc"
* media-tv/kodi: Require >=dev-cpp/waylandpp-0.1.5Craig Andrews2017-11-272-11/+11
| | | | | | See https://github.com/xbmc/xbmc/pull/13096 Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/xmltv: [QA] Consistent whitespace in metadata.xmlDavid Seifert2017-11-271-56/+56
|
* media-tv/gentoo-vdr-scripts: [QA] Consistent whitespace in metadata.xmlDavid Seifert2017-11-271-3/+3
|
* media-tv/dtv-scan-tables: New package to supersede linuxtv-dvb-appsJames Le Cuirot2017-11-264-0/+73
| | | | | | | | This doesn't need to block linuxtv-dvb-apps as they install the tables into different directories. Closes: https://bugs.gentoo.org/503028 Package-Manager: Portage-2.3.16, Repoman-2.3.6
* media-tv/v4l-utils-1.10.1-r0: alpha stableTobias Klausmann2017-11-231-1/+1
| | | | Gentoo-Bug: http://bugs.gentoo.org/631918
* media-tv/tvheadend: Export CC during configure to fix cross-compilingJames Le Cuirot2017-11-172-0/+2
| | | | | | CC isn't only used by the Makefile. Package-Manager: Portage-2.3.14, Repoman-2.3.6
* media-tv/plex-media-server: version bump to 1.9.6Jonathan Vasquez2017-11-172-0/+136
| | | | Package-Manager: Portage-2.3.12, Repoman-2.3.3
* media-tv/plex-media-server: removing 1.9.2, stabilizing 1.9.4Jonathan Vasquez2017-11-173-137/+1
| | | | Package-Manager: Portage-2.3.12, Repoman-2.3.3
* media-tv/kodi: fix app-pda/libplist dependency regarding pythonCraig Andrews2017-11-151-1/+1
| | | | Package-Manager: Portage-2.3.14, Repoman-2.3.5
* media-tv/kodi: require >=app-pda/libplist-2.0.0Craig Andrews2017-11-151-1/+1
| | | | | | See https://github.com/xbmc/xbmc/commit/46bcf9d32aa7901ea0dba5043af231e57aa26651 Package-Manager: Portage-2.3.14, Repoman-2.3.5
* media-tv/kodi: 17.6 version bumpCraig Andrews2017-11-152-0/+298
| | | | Package-Manager: Portage-2.3.14, Repoman-2.3.5
* media-tv/v4l-dvb-saa716x: Shorten DESCRIPTION, fix HOMEPAGEJonas Stein2017-11-104-9/+9
| | | | | | | Shorten DESCRIPTION Update HOMEPAGE Package-Manager: Portage-2.3.13, Repoman-2.3.4
* media-tv/kodi: Rquire net-misc/curl>=7.56.1Craig Andrews2017-10-271-1/+1
| | | | | | See https://github.com/xbmc/xbmc/commit/2177369859c8846b66fdcdb375fb243dc3a78fce Package-Manager: Portage-2.3.12, Repoman-2.3.4
* media-tv/kodi: Cleanup old versionsCraig Andrews2017-10-245-897/+0
| | | | Package-Manager: Portage-2.3.12, Repoman-2.3.3
* media-tv/kodi: 17.* requires <media-video/ffmpeg-3.4Craig Andrews2017-10-241-1/+4
| | | | | Closes: https://bugs.gentoo.org/634802 Package-Manager: Portage-2.3.12, Repoman-2.3.3
* media-tv/kodi: 17.5 version bumpCraig Andrews2017-10-233-0/+345
| | | | | Closes: https://bugs.gentoo.org/629320 Package-Manager: Portage-2.3.12, Repoman-2.3.3
* media-tv/mythtv: Fix build with glibc-2.25, bug 604430Andreas K. Hüttel2017-10-202-0/+30
| | | | | Closes: https://bugs.gentoo.org/604430 Package-Manager: Portage-2.3.12, Repoman-2.3.3
* media-tv/kodi: Bump ffmpeg to 3.4-Leia-Alpha-1Craig Andrews2017-10-162-2/+2
| | | | See https://github.com/xbmc/xbmc/pull/12926
* media-tv/kodi: x86 stable (bug #622384)Thomas Deutschmann2017-10-151-1/+1
| | | | Package-Manager: Portage-2.3.10, Repoman-2.3.3
* media-tv/plex-media-server: version bump to 1.9.4Jonathan Vasquez2017-10-112-0/+136
| | | | Package-Manager: Portage-2.3.11, Repoman-2.3.3
* media-tv/plex-media-server: version bump to 1.9.2Jonathan Vasquez2017-10-092-0/+136
| | | | Package-Manager: Portage-2.3.11, Repoman-2.3.3
* media-tv/plex-media-server: stabilizing 1.8.1, removing old versions.Jonathan Vasquez2017-10-094-273/+1
| | | | Package-Manager: Portage-2.3.11, Repoman-2.3.3
* media-tv/kodi: Bump ffmpeg to 3.3.4-Leia-Alpha-1Craig Andrews2017-10-092-2/+2
| | | | | | See https://github.com/xbmc/xbmc/pull/12894 Package-Manager: Portage-2.3.11, Repoman-2.3.3
* media-tv/shoutcast2vdr: Strip empty metadata.xml elementsMichał Górny2017-10-041-2/+0
|
* media-tv/xmltv: Fix configure/compile on Perl 5.26 re bug #630474Kent Fredric2017-09-242-13/+74
| | | | | | | | | | | Fixes: - Configure fails without '.' in @INC - Compile fails without '.' in @INC - Compile/Configure fails to use Data::Manip on machines with gentoo-install-media default setting TZ=Factory Closes: https://bugs.gentoo.org/630474 Package-Manager: Portage-2.3.6, Repoman-2.3.2
* media-tv/xmltv: Half the work to make this compatible to Perl 5.26Andreas K. Hüttel2017-09-232-1/+16
| | | | | | | | Now the configure phase works. Unfortunately the written Makefile still calls Perl, requiring modules in . Bug: https://bugs.gentoo.org/630474 Package-Manager: Portage-2.3.10, Repoman-2.3.3