aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-04-18 15:14:42 +0200
committerMarco Leise <marco.leise@gmx.de>2020-04-18 15:26:23 +0200
commita3bf07a0f74a70dac4d954dd39f8ea0f5bd70e9b (patch)
tree694f6798c77b5b4c39a9f93d8ced674ba575eefd
parentstabilization sweep (diff)
downloaddlang-a3bf07a0f74a70dac4d954dd39f8ea0f5bd70e9b.tar.gz
dlang-a3bf07a0f74a70dac4d954dd39f8ea0f5bd70e9b.tar.bz2
dlang-a3bf07a0f74a70dac4d954dd39f8ea0f5bd70e9b.zip
dfmt-0.12.0
Signed-off-by: Marco Leise <marco.leise@gmx.de>
-rw-r--r--dev-util/dfmt/Manifest2
-rw-r--r--dev-util/dfmt/dfmt-0.12.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/dfmt/Manifest b/dev-util/dfmt/Manifest
index a46a7c9..6a412d0 100644
--- a/dev-util/dfmt/Manifest
+++ b/dev-util/dfmt/Manifest
@@ -1,3 +1,5 @@
DIST dfmt-0.11.0.tar.gz 86434 BLAKE2B 36070e8b35381cc72fc8a9373202d078e36dfa7bf0a2d7dd0a0d425d3f7b3432d2458f4d5705d3fafb14f48d866b34ea874cb1d458d6976bf895a7e66683a153 SHA512 20a3e5f03d583a4fa99589fc31904f18b5d099a3307b1a229aff38d803ac05b659c92759b4aa137a54b08e9d92607f23286db164a08e314f6c3ebb6df6b9bfe6
+DIST dfmt-0.12.0.tar.gz 89416 BLAKE2B 20b18358ce6fe64c86eb8c6e440f0a855810dbc571d45497388e3e622d2fd339f75e339c7099baa15afae9730cde00cb3655cc64291834f8ceb01e57cea89d49 SHA512 1f6285824e72540bf1d41d84d8df7cf3e56e6bd3996271126a062a5f7f6532a3dcdc4e63a8bd3bdb2cb5d85eefd20c2705ded7e7c6fd4860f08573c13b719e04
+DIST libdparse-597d9a697b1f8a51fb2f441c61d0c6cc4eadc6d1.tar.gz 124830 BLAKE2B 1a7b4246b00938c44c3e32c7d0fdda4a0d343bbafad25e3e003c4672aac1dd3677a8163750b13753aa484e6bcdd120b35fc736db6d5c0be4eb3d9c78ab6a9e8e SHA512 c3b5660d455ca3dd8d22ae996ae437583b98c00e441bedfb72a5fcf8ccd4dc579e4fc8980faab501ff757ced62c079fbc116f91c796174895b33a57f0a183bbf
DIST libdparse-f512cb0b4bc11ce64eb64a710163495e425a7ad8.tar.gz 123592 BLAKE2B e463014fca952cec3cd0cfb8014f62b3749e73e12761791c23a535c5a8e467e343cfbdc48cb648baef7d4090bee7cd4db9c9406f3dad7bc0628a6eb6d008a135 SHA512 248db7c9a6a3b05c18bbed925f6219143229de50bffd7172b75003322049054b820260fc49348742172740b01324ace2f01cd7980a91ed0975d350d615747749
DIST stdx-allocator-ae237cabd1843774cc78aad0729c914a3dd579db.tar.gz 103650 BLAKE2B 8d03c2dc76194b18da92261c533c402b87bda1964662070d02ceacbab3dda91a834c0c8bfe45feb1d9a3d7669f96a2a1f7b9a6b7eff7ea53069480d8de8fe15e SHA512 893e5ecefac86a64b3a91f034cc9f42aabc264d111b40accf890b505ec9d077fcaac0b29fc202400448994e4ff021263beef7716798734cb9b71b6aad1aaf394
diff --git a/dev-util/dfmt/dfmt-0.12.0.ebuild b/dev-util/dfmt/dfmt-0.12.0.ebuild
new file mode 100644
index 0000000..067e9a1
--- /dev/null
+++ b/dev-util/dfmt/dfmt-0.12.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dfmt is a formatter for D source code"
+HOMEPAGE="https://github.com/dlang-community/dfmt"
+LICENSE="Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LIBDPARSE="597d9a697b1f8a51fb2f441c61d0c6cc4eadc6d1"
+ALLOCATOR="ae237cabd1843774cc78aad0729c914a3dd579db"
+SRC_URI="
+ https://github.com/dlang-community/dfmt/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz
+ https://github.com/dlang-community/libdparse/archive/${LIBDPARSE}.tar.gz -> libdparse-${LIBDPARSE}.tar.gz
+ https://github.com/dlang-community/stdx-allocator/archive/${ALLOCATOR}.tar.gz -> stdx-allocator-${ALLOCATOR}.tar.gz
+ "
+
+DLANG_VERSION_RANGE="2.075-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit dlang bash-completion-r1
+
+src_prepare() {
+ mkdir bin || die "Failed to create 'bin' directory."
+ cat > bin/githash.txt << EOF
+v${PV}
+EOF
+ dlang_src_prepare
+}
+
+d_src_compile() {
+ local libdparse_src="../libdparse-${LIBDPARSE}/src"
+ local allocator_src="../stdx-allocator-${ALLOCATOR}/source"
+ local imports="src ${libdparse_src} ${allocator_src}"
+ local string_imports="bin"
+
+ dlang_compile_bin "bin/dfmt" "src/dfmt/main.d" "src/dfmt/config.d" "src/dfmt/editorconfig.d" \
+ "src/dfmt/ast_info.d" "src/dfmt/indentation.d" "src/dfmt/tokens.d" "src/dfmt/wrapping.d" \
+ "src/dfmt/formatter.d" "src/dfmt/globmatch_editorconfig.d" \
+ ${libdparse_src}/dparse/lexer.d ${libdparse_src}/dparse/parser.d ${libdparse_src}/dparse/ast.d \
+ ${libdparse_src}/dparse/rollback_allocator.d ${libdparse_src}/dparse/stack_buffer.d \
+ ${libdparse_src}/std/experimental/lexer.d \
+ ${allocator_src}/stdx/allocator/common.d ${allocator_src}/stdx/allocator/internal.d \
+ ${allocator_src}/stdx/allocator/mallocator.d ${allocator_src}/stdx/allocator/package.d \
+ ${allocator_src}/stdx/allocator/gc_allocator.d ${allocator_src}/stdx/allocator/typed.d
+}
+
+d_src_test() {
+ cd tests && ./test.sh
+}
+
+d_src_install() {
+ dobin bin/dfmt
+ dodoc README.md LICENSE.txt
+ dobashcomp bash-completion/completions/dfmt
+}