aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2019-03-04 15:54:51 +0100
committerMarco Leise <marco.leise@gmx.de>2019-03-04 15:54:51 +0100
commitfee8b14cb2a6b9a2e743070ef1e7abe7b6007c5b (patch)
treec775097235ce67dda71dd419c2e978a214a6d896 /dev-util
parentdmd-2.085 (diff)
downloaddlang-fee8b14cb2a6b9a2e743070ef1e7abe7b6007c5b.tar.gz
dlang-fee8b14cb2a6b9a2e743070ef1e7abe7b6007c5b.tar.bz2
dlang-fee8b14cb2a6b9a2e743070ef1e7abe7b6007c5b.zip
dub-1.14.0
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dub/Manifest1
-rw-r--r--dev-util/dub/dub-1.14.0.ebuild39
-rw-r--r--dev-util/dub/files/dub-1.14.0-gdc-dmd-pathfix.patch16
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/dub/Manifest b/dev-util/dub/Manifest
index 5c9404b..d2b308a 100644
--- a/dev-util/dub/Manifest
+++ b/dev-util/dub/Manifest
@@ -1 +1,2 @@
DIST dub-1.13.0.tar.gz 1271379 BLAKE2B 749ac67e99ab3959451cbd316f6936d50c25e68c32cbbc5075c17444b23f41e863a929d42f520a1bef2f7c6eff510814bf021e08baca1c73918435fb38b0ac70 SHA512 9d9a3f22ef4ae28e117e2d14b6837a975b66316e99dad4de9c9def278a40e567d1f6d73f56381a49a4ddd2d96b86910eccb335171439701a282e4f1ce8630422
+DIST dub-1.14.0.tar.gz 1277574 BLAKE2B 7b1bac4dc5789202eac150d63e230dbb10efdc0a32e9d33b778498c212fbdd974bca9c1f53602a9ee0cbab55d3d8bcb741f847be132674fe2c28846f5ab7c707 SHA512 aa1ef282021c6d090b5f6b485904b3e207b0acd67b42dd169c817ee7e9af24a69055b3eb1e1bad3c61f37ac47ce63bc1cf590b5d5dfd838abbcfe054f192be49
diff --git a/dev-util/dub/dub-1.14.0.ebuild b/dev-util/dub/dub-1.14.0.ebuild
new file mode 100644
index 0000000..dc1000d
--- /dev/null
+++ b/dev-util/dub/dub-1.14.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Package and build management system for D"
+HOMEPAGE="http://code.dlang.org/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+GITHUB_URI="https://codeload.github.com/dlang"
+SRC_URI="${GITHUB_URI}/${PN}/tar.gz/v${PV} -> ${PN}-${PV}.tar.gz"
+PATCHES="${FILESDIR}/${P}-gdc-dmd-pathfix.patch"
+
+DLANG_VERSION_RANGE="2.072-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit dlang
+
+DEPEND="net-misc/curl"
+RDEPEND="${DEPEND}"
+
+d_src_compile() {
+ local imports=source versions="DubApplication DubUseCurl" libs="curl z"
+ dlang_compile_bin bin/dub $(<build-files.txt)
+}
+
+d_src_test() {
+ echo "Test phase disabled due to multiple problems."
+ #DUB="${S}/bin/dub" test/run-unittest.sh || die "Test phase failed"
+}
+
+d_src_install() {
+ dobin bin/dub
+ dodoc README.md
+}
diff --git a/dev-util/dub/files/dub-1.14.0-gdc-dmd-pathfix.patch b/dev-util/dub/files/dub-1.14.0-gdc-dmd-pathfix.patch
new file mode 100644
index 0000000..497ef50
--- /dev/null
+++ b/dev-util/dub/files/dub-1.14.0-gdc-dmd-pathfix.patch
@@ -0,0 +1,16 @@
+diff --git a/source/dub/generators/build.d b/source/dub/generators/build.d
+--- a/source/dub/generators/build.d
++++ b/source/dub/generators/build.d
+@@ -119,10 +119,10 @@ class BuildGenerator : ProjectGenerator {
+ auto build_id = computeBuildID(config, buildsettings, settings);
+
+ // make all paths relative to shrink the command line
+- string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
++ /+string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
+ foreach (ref f; buildsettings.sourceFiles) f = makeRelative(f);
+ foreach (ref p; buildsettings.importPaths) p = makeRelative(p);
+- foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);
++ foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);+/
+
+ // perform the actual build
+ bool cached = false;