aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2018-11-26 11:12:31 +0100
committerGerion Entrup <gerion.entrup@flump.de>2018-11-26 11:15:18 +0100
commit22253584c295ba3113dc4a775b4cd4a30c57c5d1 (patch)
treeaa641bc0deba2cf28e05266e6f31d033cf70c075
parentdev-python/junit2html: add for zephyr (diff)
downloadgerislay-22253584c295ba3113dc4a775b4cd4a30c57c5d1.tar.gz
gerislay-22253584c295ba3113dc4a775b4cd4a30c57c5d1.tar.bz2
gerislay-22253584c295ba3113dc4a775b4cd4a30c57c5d1.zip
dev-vcs/gitlint: add for zephyr
Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--dev-vcs/gitlint/Manifest2
-rw-r--r--dev-vcs/gitlint/gitlint-0.10.0.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-vcs/gitlint/Manifest b/dev-vcs/gitlint/Manifest
new file mode 100644
index 0000000..78b1ab4
--- /dev/null
+++ b/dev-vcs/gitlint/Manifest
@@ -0,0 +1,2 @@
+DIST gitlint-0.10.0.tar.gz 124351 BLAKE2B d599a72a7c908e8674545db9b2131026a9a792e0151f8e37c3b9d6cb3271d1b92071b55d681debb61704d981ab9633d82cc7d0544a40745c178c1e9da28667e0 SHA512 44a021b87e9fa2cea81b112c11e01ff1c05baa6d128ddbb89d6d4b58f17b80e42a888b690fa8c624b646b5d97372e8d5aa18ff0d1bb3b5d7c7a1695a48f660ee
+EBUILD gitlint-0.10.0.ebuild 622 BLAKE2B 8c6560cad625ffb3ca70a406ac0be7083a16199c341d1e04ca5343fa56f68fe7a7b46553373206c24f2c8542153719caf9de3c914189bb19c002748e903ea442 SHA512 ce1dce509b94155b8a0e7c3532ee6ed5a69c0e82d90997662a4f9294e8c1f9b9f8384b3fa6fc05231823d7b7e523a9c3d9f7a48a46db002bef8ea2afdb6278c6
diff --git a/dev-vcs/gitlint/gitlint-0.10.0.ebuild b/dev-vcs/gitlint/gitlint-0.10.0.ebuild
new file mode 100644
index 0000000..dd046b2
--- /dev/null
+++ b/dev-vcs/gitlint/gitlint-0.10.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Linting for your git commit messages"
+HOMEPAGE="https://github.com/jorisroovers/gitlint"
+SRC_URI="https://github.com/jorisroovers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/sh[${PYTHON_USEDEP}]
+ dev-python/arrow[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"