aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-11-03 19:40:23 +0100
committerGerion Entrup <gerion.entrup@flump.de>2024-11-03 19:40:23 +0100
commit6e9eca03b6bc78b9faa820f6ce1729d1932b7340 (patch)
treee7cb6737b77789f13a852bfc14c3fe5ab8679f41 /dev-python/graph-tool/graph-tool-2.79.ebuild
parentdev-debug/lldb:14: add manifest (diff)
downloadgerislay-6e9eca03b6bc78b9faa820f6ce1729d1932b7340.tar.gz
gerislay-6e9eca03b6bc78b9faa820f6ce1729d1932b7340.tar.bz2
gerislay-6e9eca03b6bc78b9faa820f6ce1729d1932b7340.zip
dev-python/graph-tool: add 2.79
Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
Diffstat (limited to 'dev-python/graph-tool/graph-tool-2.79.ebuild')
-rw-r--r--dev-python/graph-tool/graph-tool-2.79.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/graph-tool/graph-tool-2.79.ebuild b/dev-python/graph-tool/graph-tool-2.79.ebuild
new file mode 100644
index 0000000..933f090
--- /dev/null
+++ b/dev-python/graph-tool/graph-tool-2.79.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit check-reqs python-r1 toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://git.skewed.de/count0/graph-tool.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://downloads.skewed.de/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="An efficient python module for manipulation and statistical analysis of graphs"
+HOMEPAGE="https://graph-tool.skewed.de/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+cairo openmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[context,python,${PYTHON_USEDEP}]
+ dev-libs/expat
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ sci-mathematics/cgal:=
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ cairo? (
+ dev-cpp/cairomm:0
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/cairo[X]
+ )"
+DEPEND="${RDEPEND}
+ dev-cpp/sparsehash"
+BDEPEND="virtual/pkgconfig"
+
+# bug 453544
+CHECKREQS_DISK_BUILD="6G"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ my_configure() {
+ econf \
+ --disable-static \
+ $(use_enable openmp) \
+ $(use_enable cairo) \
+ --with-boost-python="boost_${EPYTHON/./}"
+ }
+ python_foreach_impl run_in_build_dir my_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir emake
+}
+
+src_install() {
+ my_python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir my_python_install
+
+ find "${ED}" -name '*.la' -delete || die
+}