aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2018-05-18 13:36:22 +0200
committerGerion Entrup <gerion.entrup@flump.de>2018-05-18 13:36:22 +0200
commita029f2cae33ae12b9632e5599f6d5314dd299a85 (patch)
treeab01456af2fe623ddfb39ad7c190fa9f6264f8ef /dev-python/rauth/rauth-0.7.2.ebuild
parentopenrct2: drop, it's in the gentoo tree (diff)
downloadgerislay-a029f2cae33ae12b9632e5599f6d5314dd299a85.tar.gz
gerislay-a029f2cae33ae12b9632e5599f6d5314dd299a85.tar.bz2
gerislay-a029f2cae33ae12b9632e5599f6d5314dd299a85.zip
add dev-python/rauth
Diffstat (limited to 'dev-python/rauth/rauth-0.7.2.ebuild')
-rw-r--r--dev-python/rauth/rauth-0.7.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/rauth/rauth-0.7.2.ebuild b/dev-python/rauth/rauth-0.7.2.ebuild
new file mode 100644
index 0000000..2635e72
--- /dev/null
+++ b/dev-python/rauth/rauth-0.7.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A Python library for OAuth 1.0/a, 2.0, and Ofly."
+HOMEPAGE="https://github.com/litl/rauth"
+SRC_URI="https://github.com/litl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"