aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2019-05-02 13:36:32 +0200
committerGerion Entrup <gerion.entrup@flump.de>2019-05-24 12:47:40 +0200
commitaf228896374324d0bb52f03aee810490b2313603 (patch)
tree230bfad61207df9bbb663baa50b0a547754dbd55 /dev-python/rauth/rauth-0.7.2.ebuild
parentmedia-plugins/hyperion: qt5 is mandatory (diff)
downloadgerislay-af228896374324d0bb52f03aee810490b2313603.tar.gz
gerislay-af228896374324d0bb52f03aee810490b2313603.tar.bz2
gerislay-af228896374324d0bb52f03aee810490b2313603.zip
dev-python/rauth: python 3.6 and 3.7 support
Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
Diffstat (limited to 'dev-python/rauth/rauth-0.7.2.ebuild')
-rw-r--r--dev-python/rauth/rauth-0.7.2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/rauth/rauth-0.7.2.ebuild b/dev-python/rauth/rauth-0.7.2.ebuild
index 2635e72..c0d0383 100644
--- a/dev-python/rauth/rauth-0.7.2.ebuild
+++ b/dev-python/rauth/rauth-0.7.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
DESCRIPTION="A Python library for OAuth 1.0/a, 2.0, and Ofly."
@@ -15,6 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+PATCHES=( "${FILESDIR}/${P}-fix-python-3.6.patch" )
+
DEPEND="
dev-python/requests[${PYTHON_USEDEP}]
test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"