aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/odns/odns-0.3.ebuild')
-rw-r--r--dev-ml/odns/odns-0.3.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ml/odns/odns-0.3.ebuild b/dev-ml/odns/odns-0.3.ebuild
deleted file mode 100644
index e330cf1..0000000
--- a/dev-ml/odns/odns-0.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit findlib eutils
-
-DESCRIPTION="OCaml library to query DNS servers"
-HOMEPAGE="http://odns.tuxfamily.org/"
-SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-# odns-0.3 causes file collisions.
-# It is ancient and upstream is dead. Consider using ocaml-dns instead.
-RDEPEND="
- >=dev-lang/ocaml-3.10.2:=[ocamlopt]
- !dev-ml/ocaml-dns
-"
-DEPEND="${RDEPEND}"
-
-CLIBS="" # Workaround for bug #422683
-
-src_prepare() {
- sed -i -e "s/version=\"0.2\"/version=\"${PV}\"/" META || die
- epatch "${FILESDIR}/${P}-parmake.patch"
-}
-
-src_compile() {
- emake -j1 #453434
-}
-
-src_install() {
- findlib_src_preinst
- PREFIX="${D}/usr" emake install
- dodoc AUTHORS README
-}