aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Update Copyright yearHEADmasterBrian Evans2018-08-261-1/+1
| | | | Signed-off-by: Brian Evans <grknight@gentoo.org>
* False instead of strict, strict is for types.dynamic2Alec Warner2018-08-251-1/+1
|
* Turn off dynamic field detection.dynamicAlec Warner2018-08-251-1/+2
|
* Remove PFL links as they are longer working.Bruno Pinto2018-07-222-9/+0
| | | | | Closes: 653846 Signed-off-by: Alec Warner <antarus@gentoo.org>
* Go back to old changelog behavior for now.v6.0.23Alec Warner2018-07-171-3/+0
|
* Fix p.g.o versioning.v6.0.22Alec Warner2018-07-081-1/+1
| | | | Bug: https://bugs.gentoo.org/attachment.cgi?id=538714&action=edit
* Try to fix Build.Alec Warner2018-06-171-1/+1
| | | | | | | | CI said: Gem::LoadError: You have already activated did_you_mean 1.2.0, but your Gemfile requires did_you_mean 1.0.2. Prepending `bundle exec` to your command may solve this. So bumping to a versionless did_you_mean.
* Stop testing ruby-2.2.X.Alec Warner2018-06-171-1/+0
| | | | We require ruby-2.3 at least.
* Test rails 5.Alec Warner2018-06-172-0/+55
| | | | | Add a new Gemfile.ci to test rails 5. Add the gemfile.ci to the build matrix.
* Only CI master branch for now.Alec Warner2018-06-171-0/+4
|
* Add redis to test suite.Alec Warner2018-06-171-0/+1
|
* Upgrade rails to avoid security bugs.v6.0.21Alec Warner2018-06-162-32/+32
|
* Bump Gemfile.lock.v6.0.20Alec Warner2018-06-161-0/+2
|
* Try to cherry-pick robin's fix.v6.0.19Alec Warner2018-06-161-0/+3
|
* Update gems.v6.0.18v6.0.17Alec Warner2018-06-161-9/+9
|
* Add arm64 column to "Available versions"/KEYWORDs table dataMichael Everitt2018-05-084-1/+4
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* Bump again to test mirroring.Alec Warner2018-05-021-1/+1
|
* Bump to push to github.Alec Warner2018-05-021-1/+1
|
* Add rails 2.5Alec Warner2018-05-022-4/+1
| | | | Drop setup code, it appears broken.
* Add indexes before running tests.Alec Warner2018-04-281-0/+1
|
* Install ES in testing.Alec Warner2018-04-281-0/+5
|
* Enable bundler caching.Alec Warner2018-04-281-0/+1
|
* Copy dist to main file in before_script.Alec Warner2018-04-281-0/+3
|
* Only Test ruby 2.2Alec Warner2018-04-283-10/+9
| | | | Comment out busted packages_helper code to assist in tests passing.
* Update Gems.Alec Warner2018-04-281-25/+25
|
* Revamp ruby versions.Alec Warner2018-04-281-2/+1
| | | | I also modified the travis config online to set SECRET_KEY_BASE
* Add Travis integration.Alec Warner2018-04-281-0/+5
|
* Add space to trigger mirror, third pass.Alec Warner2018-04-281-1/+1
|
* Commit to trigger mirror.Alec Warner2018-04-281-1/+0
|
* Space change to try to trigger a gitolite mirror.Alec Warner2018-04-281-1/+1
|
* Move web console to :development only.Alec Warner2018-04-221-1/+1
| | | | Rails complains when we run it in test, so don't.
* Annotate the bug list with a Bugs: prefix.v6.0.16Alec Warner2018-04-161-1/+1
|
* Fix bug annotations.Alec Warner2018-04-162-1/+13
| | | | | | | | | | Instead of showing the entire commit message, look for glep66 headers in the commit body and pull out the list of bugs. Then annotate each bug # as a link. Then join the links into a list like: 12345,56788,12456 Each number is a link to the bug.
* Try joining with <br>v6.0.15Alec Warner2018-04-101-1/+1
|
* safe_join is not an array function.v6.0.14Alec Warner2018-04-081-1/+1
|
* s/join/safe_join/.v6.0.13Alec Warner2018-04-081-1/+1
|
* Join the annotated lines into a string.v6.0.12Alec Warner2018-04-081-1/+1
|
* Don't repeat the first line.Alec Warner2018-04-071-1/+1
|
* Move commit out of <strong>v6.0.11Alec Warner2018-04-071-1/+3
| | | | Still annotate the entire commit.
* Annotate each line in the changelog.v6.0.10Alec Warner2018-04-071-1/+1
|
* Annotate and show the entire commit message.v6.0.9Alec Warner2018-04-061-1/+1
| | | | Closes: http://bugs.gentoo.org/652712
* Also update view.v6.0.8Alec Warner2018-02-261-1/+1
| | | | Missed this in last commit.
* Revert "Uniqify versions in the UI for the moment."v6.0.7Alec Warner2018-02-261-4/+1
| | | | | | | This reverts commit 65e1fb72f583e3f3e2ce00bc78ae4d5c6ed45fc6. We need to test our indexer fix, we will do this on master and push ptest to 6.0.7 to verify.
* Fix broken deletion of versions in import code.v6.0.6Alec Warner2018-02-261-1/+1
| | | | | | The previous version relied on elastic search matching packages based solely on package name (e.g. "gentoo-sources") but in order to collect the version from the index, an entire atom is required.
* Use new unique_versions view in package show UI.v6.0.5Alec Warner2018-02-251-1/+1
|
* Uniqify versions in the UI for the moment.v6.0.4Alec Warner2018-02-251-1/+4
| | | | | The indexer is still doing naughty things, but we can patch the UI to uniqify versions until we fix the index.
* Mark bin/first-run as executable.Alec Warner2018-02-251-0/+0
|
* Add a script to ease first-run setup.Alec Warner2018-02-251-0/+8
|
* kkuleomi/store: bump field limit.v6.0.3Robin H. Johnson2018-02-211-1/+1
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* Push the size param into the aggregation part.v6.0.2Alec Warner2018-02-181-3/+6
| | | | | | | | | | According to https://www.elastic.co/guide/en/elasticsearch/reference/current/search-aggregations-bucket-terms-aggregation.html this controls the number of buckets (defaulting to 10 apparently). This was changed in ES5 but went unnoticed until now. Force to 10k buckets to continue to support flags with *lots* of packages and revisit in the future if too expensive.