summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-02-12 07:25:13 -0500
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-02-12 07:25:13 -0500
commitb3535ed0cb7acf731afe93f0ad255044db296c4f (patch)
treefc9f525d80a9a33daa72a035a9af880ca741c36e
parentPatching shebangs to work when python3.2 is selected as default python versio... (diff)
downloadArmageddon-b3535ed0cb7acf731afe93f0ad255044db296c4f.tar.gz
Armageddon-b3535ed0cb7acf731afe93f0ad255044db296c4f.tar.bz2
Armageddon-b3535ed0cb7acf731afe93f0ad255044db296c4f.zip
Subdownloader version bump to 2.0.18...
-rw-r--r--media-video/subdownloader/Manifest1
-rw-r--r--media-video/subdownloader/subdownloader-2.0.18.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-video/subdownloader/Manifest b/media-video/subdownloader/Manifest
index 28d0c64..1fc9a5f 100644
--- a/media-video/subdownloader/Manifest
+++ b/media-video/subdownloader/Manifest
@@ -1,2 +1,3 @@
DIST subdownloader-2.0.14.tar.gz 1012349 SHA256 b383729144178a42a15fff3d65d2daa5f23be6f1f35660dac9bced64ad91ae52
DIST subdownloader-2.0.16_p20120910.tar.gz 6074595 SHA256 d390c45c7d6a8f0ae0d0ea706609c5c723a99973eb0d6a2dc2b77a6aa04b2aea SHA512 ae819ad76deeb97f3d12dd9348662c0a351e223a88ab20c7fb0be92c1b0cda027d78ee7f1e80341a01e32a8d424f621baf458ae8f96ce344546618d946a0499f WHIRLPOOL 4416ceda51c7237015480ebf2e8ff4659d12bd5e58e7b33a78d54d19bf54a12622a2c81189498d604273f28978e549ac38b3b8f68955ca9a312d6751baf21bac
+DIST subdownloader-2.0.18.tar.gz 1259520 SHA256 2f9ec46d1537cb5677b717dcaf5668cdc61a84456bc52178b40595759ba35655 SHA512 ecddf606ce374af43fff39c225ee896af4d8bd2384a2f300dcbb4b443377807edd5233a0531e95d338b0f9c84a274b3afd4109d9216510a5a4bc8fa17485b999 WHIRLPOOL 2b735f0c25a19a49444011a81b28b855d3ce4b2ba01f1efbc65d9f4fe3f541081db13805d99d9a8e52cbb3ef3b95dae3fa80c3f9a06023c629285f4dd9dca5ac
diff --git a/media-video/subdownloader/subdownloader-2.0.18.ebuild b/media-video/subdownloader/subdownloader-2.0.18.ebuild
new file mode 100644
index 0000000..bf567f4
--- /dev/null
+++ b/media-video/subdownloader/subdownloader-2.0.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit python eutils
+
+DESCRIPTION="GUI application for automatic downloading/uploading of subtitles for videofiles"
+HOMEPAGE="http://www.subdownloader.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_2.0.18.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/subdownloader-${PV}"
+
+DEPEND="
+ dev-python/PyQt4
+ dev-python/kaa-metadata"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 "${S}"/run.py
+}
+
+src_install() {
+ insinto /usr/share/"${PN}"
+ doins -r cli FileManagement gui languages locale modules run.py
+ fperms 755 /usr/share/"${PN}"/run.py
+ dosym /usr/share/"${PN}"/run.py /usr/bin/"${PN}"
+ doman subdownloader.1
+ dodoc README ChangeLog
+ doicon gui/images/subdownloader.png
+ domenu subdownloader.desktop
+}