summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-11-07 14:54:34 -0500
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-11-07 14:54:34 -0500
commitb8f5575dedb475811555fddc4a087b048e1c0fcb (patch)
treeabd28c5461f76c053068d5996ad5cc7dddc47f4c
parentSubdownloader version bump to 2.0.16-2 (diff)
downloadArmageddon-b8f5575dedb475811555fddc4a087b048e1c0fcb.tar.gz
Armageddon-b8f5575dedb475811555fddc4a087b048e1c0fcb.tar.bz2
Armageddon-b8f5575dedb475811555fddc4a087b048e1c0fcb.zip
TeamViewer version bump, thank you Mikael...
-rw-r--r--net-misc/teamviewer/Manifest1
-rw-r--r--net-misc/teamviewer/teamviewer-7.0.9377.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index dee233c..783a4da 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -1 +1,2 @@
DIST teamviewer-7.0.9360.tar.gz 18077695 SHA256 0cfc821360b1157da8e6b3d041e7031e8f5e541a0b6363757fc3f364d05e9261 SHA512 95706f5071a17de37ab7dd933fdad444b2d6f1470a9e3899b14575249ced76379c77ca7fdd3d52259b90e405ce1c5e3bac70d92d17b55d1baa6c58e936c0215c WHIRLPOOL 8f756b78f99e55916237881c8bccf91046727bd55b0899b48836cc2487ccbf8e646d2f47c37527a422169c13e230ff7c56d2e0e8fe643970c6bcd4cd59019fcf
+DIST teamviewer-7.0.9377.tar.gz 18102617 SHA256 3eaa78cbbd49449f2dbe5be6f0af99535a039598867a537ea8230189251909b9 SHA512 cc959dc9d243be499dbd5781c979305787659fbc95f72f5cb5e05dc042006cf05e670e8feb88322a1adf74f1c58cdf8883c11945a5baff26b0a7a2a4e8b08a8b WHIRLPOOL 68cc97298d8f98b5021e39954f45167eb2b32ff3bd32aa38733120574dafcf13884e452823ccec9d73f3244989433919395ba6d357f714635a1a6276bd8fa855
diff --git a/net-misc/teamviewer/teamviewer-7.0.9377.ebuild b/net-misc/teamviewer/teamviewer-7.0.9377.ebuild
new file mode 100644
index 0000000..4cebe0f
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-7.0.9377.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="http://www.teamviewer.com"
+SRC_URI="http://www.teamviewer.com/download/${PN}_linux.tar.gz -> ${P}.tar.gz"
+
+LICENSE="TeamViewer"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="mirror strip"
+
+RDEPEND="app-emulation/wine"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/teamviewer7"
+
+src_install () {
+ rm ${PN}
+ echo "#!/bin/bash" > ${PN}
+ echo "wine /opt/${PN}/TeamViewer.exe" >> ${PN}
+
+ insinto /opt/${PN}/
+ doins .wine/drive_c/Program\ Files/TeamViewer/Version7/*
+ doins ${PN}
+
+ fperms 755 /opt/${PN}/${PN}
+ dosym /opt/${PN}/${PN} /opt/bin/${PN}
+
+ doicon -s 48 .tvscript/${PN}.png
+
+ dodoc linux_FAQ_{EN,DE}.txt
+ dodoc CopyRights_{EN,DE}.txt
+
+ make_desktop_entry ${PN} TeamViewer \
+ /opt/${PN}/.tvscript/${PN}.png 'Network;'
+
+}