summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-07 11:41:05 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-07 11:41:05 -0400
commited16e3202de40417b7b1f96279b167eb5aacba15 (patch)
treed8dcdb6ef8abfa77f6b32b74486778cab0e4eee3 /media-video
parentCreated a COMMON_DEPEND variable to hold redundancies of DEPEND and (diff)
downloadArmageddon-ed16e3202de40417b7b1f96279b167eb5aacba15.tar.gz
Armageddon-ed16e3202de40417b7b1f96279b167eb5aacba15.tar.bz2
Armageddon-ed16e3202de40417b7b1f96279b167eb5aacba15.zip
Added an ebuild draft for subdownloader-2.0.14
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subdownloader/Manifest1
-rw-r--r--media-video/subdownloader/subdownloader-2.0.14.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-video/subdownloader/Manifest b/media-video/subdownloader/Manifest
new file mode 100644
index 0000000..ef665c0
--- /dev/null
+++ b/media-video/subdownloader/Manifest
@@ -0,0 +1 @@
+DIST subdownloader-2.0.14.tar.gz 1012349 RMD160 34fbe315a45d177c82230176036e53e18b14eae5 SHA1 64ab7fd9e77726e9c271d0dda7de21eee90dc569 SHA256 b383729144178a42a15fff3d65d2daa5f23be6f1f35660dac9bced64ad91ae52
diff --git a/media-video/subdownloader/subdownloader-2.0.14.ebuild b/media-video/subdownloader/subdownloader-2.0.14.ebuild
new file mode 100644
index 0000000..9446424
--- /dev/null
+++ b/media-video/subdownloader/subdownloader-2.0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit python eutils
+
+DESCRIPTION="GUI application for automatic download/upload subtitles for
+videofiles"
+HOMEPAGE="http://www.subdownloader.net/"
+SRC_URI="http://launchpad.net/subdownloader/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt4
+ dev-python/sip"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/$(get_libdir)/subdownloader
+ doins -r cli FileManagement gui languages locale modules run.py || die "doins failed"
+ fperms 755 /usr/$(get_libdir)/subdownloader/run.py
+ dosym /usr/$(get_libdir)/subdownloader/run.py /usr/bin/subdownloader
+ doman subdownloader.1 || die "doman failed"
+ dodoc README ChangeLog || die "dodoc failed"
+ doicon gui/images/subdownloader.png || die "doicon failed"
+ domenu subdownloader.desktop || die "domenu failed"
+}