summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/curseofwar/curseofwar-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/games-strategy/curseofwar/curseofwar-9999.ebuild b/games-strategy/curseofwar/curseofwar-9999.ebuild
index 7769617..d34e556 100644
--- a/games-strategy/curseofwar/curseofwar-9999.ebuild
+++ b/games-strategy/curseofwar/curseofwar-9999.ebuild
@@ -13,11 +13,12 @@ EGIT_REPO_URI="https://github.com/a-nikolaev/${PN}.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="sdl"
RDEPEND="
app-shells/bash
- sys-libs/ncurses"
+ sys-libs/ncurses
+ sdl? ( media-libs/libsdl )"
DEPEND="${RDEPEND}
sys-devel/gcc"
@@ -27,3 +28,13 @@ src_configure() {
sed -i -e 's/LDFLAGS\ =/LDFLAGS\ \+=/' Makefile || \
die "couldn't patch Makefile LDFLAGS"
}
+
+src_compile() {
+ local myconf=""
+
+ if use sdl; then
+ myconf+="SDL=yes"
+ fi
+
+ emake ${myconf}
+}