summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/vim-qt/vim-qt-9999.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/app-editors/vim-qt/vim-qt-9999.ebuild b/app-editors/vim-qt/vim-qt-9999.ebuild
index 3783a53..6dc6441 100644
--- a/app-editors/vim-qt/vim-qt-9999.ebuild
+++ b/app-editors/vim-qt/vim-qt-9999.ebuild
@@ -4,13 +4,12 @@
EAPI=4
-inherit toolchain-funcs git-2
+inherit eutils toolchain-funcs git-2
DESCRIPTION="Qt GUI version of the Vim text editor"
HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/overview"
EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git
https://gitorious.org/${PN}/${PN}.git"
-SRC_URI=""
LICENSE="vim"
SLOT="0"
@@ -18,39 +17,32 @@ KEYWORDS=""
IUSE="acl cscope debug gpm nls perl python ruby"
COMMON_DEPEND="
- >=app-admin/eselect-vi-1.1
+ app-admin/eselect-vi
=app-editors/vim-core-7.3.487
- >=sys-libs/ncurses-5.2-r2
+ sys-libs/ncurses
>=x11-libs/qt-core-4.7.0:4
>=x11-libs/qt-gui-4.7.0:4
acl? ( kernel_linux? ( sys-apps/acl ) )
cscope? ( dev-util/cscope )
- gpm? ( >=sys-libs/gpm-1.19.3 )
+ gpm? ( sys-libs/gpm )
nls? ( virtual/libintl )
perl? ( dev-lang/perl )
- ruby? ( =dev-lang/ruby-1.8* )"
+ ruby? ( dev-lang/ruby:1.8 )"
DEPEND="${COMMON_DEPEND}
- >=sys-apps/sed-4
sys-devel/autoconf"
-RDEPEND="${COMMON_DEPEND}
- !<app-vim/align-30-r1
- !<app-vim/autoalign-11
- !<app-vim/vimbuddy-0.9.1-r1
- !<app-vim/supertab-0.41"
+RDEPEND="${COMMON_DEPEND}"
src_configure() {
- local myconf
-
use debug && append-flags "-DDEBUG"
- myconf="--with-features=huge
+ local myconf="--with-features=huge
--enable-multibyte"
+ myconf+=" $(use_enable acl)"
myconf+=" $(use_enable gpm)"
+ myconf+=" $(use_enable nls)"
myconf+=" $(use_enable perl perlinterp)"
myconf+=" $(use_enable python pythoninterp)"
myconf+=" $(use_enable ruby rubyinterp)"
- myconf+=" $(use_enable nls)"
- myconf+=" $(use_enable acl)"
myconf+=" --enable-gui=qt --with-vim-name=qvim --with-x"
if ! use cscope ; then
@@ -62,4 +54,6 @@ src_configure() {
src_install() {
dobin src/qvim
+ doicon -s 64 src/qt/icons/vim-qt.png
+ make_desktop_entry qvim Vim-qt vim-qt "QT;TextEditor;Development;"
}