summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/subdownloader/Manifest3
-rw-r--r--media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild33
2 files changed, 35 insertions, 1 deletions
diff --git a/media-video/subdownloader/Manifest b/media-video/subdownloader/Manifest
index ef665c0..28d0c64 100644
--- a/media-video/subdownloader/Manifest
+++ b/media-video/subdownloader/Manifest
@@ -1 +1,2 @@
-DIST subdownloader-2.0.14.tar.gz 1012349 RMD160 34fbe315a45d177c82230176036e53e18b14eae5 SHA1 64ab7fd9e77726e9c271d0dda7de21eee90dc569 SHA256 b383729144178a42a15fff3d65d2daa5f23be6f1f35660dac9bced64ad91ae52
+DIST subdownloader-2.0.14.tar.gz 1012349 SHA256 b383729144178a42a15fff3d65d2daa5f23be6f1f35660dac9bced64ad91ae52
+DIST subdownloader-2.0.16_p20120910.tar.gz 6074595 SHA256 d390c45c7d6a8f0ae0d0ea706609c5c723a99973eb0d6a2dc2b77a6aa04b2aea SHA512 ae819ad76deeb97f3d12dd9348662c0a351e223a88ab20c7fb0be92c1b0cda027d78ee7f1e80341a01e32a8d424f621baf458ae8f96ce344546618d946a0499f WHIRLPOOL 4416ceda51c7237015480ebf2e8ff4659d12bd5e58e7b33a78d54d19bf54a12622a2c81189498d604273f28978e549ac38b3b8f68955ca9a312d6751baf21bac
diff --git a/media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild b/media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild
new file mode 100644
index 0000000..422fef5
--- /dev/null
+++ b/media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit python eutils
+
+DESCRIPTION="GUI application for automatic downloading/uploading of subtitles for videofiles"
+HOMEPAGE="http://www.subdownloader.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/2.0.16-2/+download/${PN}_2.10.6-2.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/subdownloader"
+
+DEPEND="
+ dev-python/PyQt4
+ dev-python/kaa-metadata"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/share/"${PN}"
+ doins -r cli FileManagement gui languages locale modules run.py
+ fperms 755 /usr/share/"${PN}"/run.py
+ dosym /usr/share/"${PN}"/run.py /usr/bin/"${PN}"
+ doman subdownloader.1
+ dodoc README ChangeLog
+ doicon gui/images/subdownloader.png
+ domenu subdownloader.desktop
+}