summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-engines/solarus/Manifest1
-rw-r--r--games-engines/solarus/metadata.xml (renamed from x11-apps/grandr/metadata.xml)6
-rw-r--r--games-engines/solarus/solarus-1.0.4.ebuild38
-rw-r--r--games-rpg/zsdx/Manifest1
-rw-r--r--games-rpg/zsdx/metadata.xml9
-rw-r--r--games-rpg/zsdx/zsdx-1.6.2.ebuild32
-rw-r--r--x11-apps/grandr/Manifest1
-rw-r--r--x11-apps/grandr/files/0.1-fix-combo-invalid-iterator.patch16
-rw-r--r--x11-apps/grandr/files/0.1-fix-license-display.patch42
-rw-r--r--x11-apps/grandr/files/0.1-fix-segfault-without-gconf-value.patch13
-rw-r--r--x11-apps/grandr/files/0.1-outpus.patch33
-rw-r--r--x11-apps/grandr/grandr-0.1-r2.ebuild21
12 files changed, 84 insertions, 129 deletions
diff --git a/games-engines/solarus/Manifest b/games-engines/solarus/Manifest
new file mode 100644
index 0000000..1885996
--- /dev/null
+++ b/games-engines/solarus/Manifest
@@ -0,0 +1 @@
+DIST solarus-1.0.4-src.tar.gz 702674 SHA256 03cabfd6f13210c5c96227442a19b3157054ba5700f7749f43696fa8d8dbf6f5 SHA512 c3e256d1baacfb8456e0effe85b6d75acc18c9f38b2c7650143cccf1ce4f610225d73d876cdef71d07a6ecb0f4dc7455dee142c12e6b003713fde2ad5870de7f WHIRLPOOL 7c2d8317faf898b67ef57056b8c4db827f489ff10ec2e7bac3f957f0cef4b878a51c00251336b474d55d9d5c6e95f34b20abb1ac58f5ae47a6f74200c9dcc958
diff --git a/x11-apps/grandr/metadata.xml b/games-engines/solarus/metadata.xml
index b4fa3cb..e92b959 100644
--- a/x11-apps/grandr/metadata.xml
+++ b/games-engines/solarus/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>x11</herd>
- <comaintainer>
+ <maintainer>
<email>ThyArmageddon+Gentoo@Gmail.com</email>
<name>Elijah El Lazkani</name>
- </comaintainer>
+ </maintainer>
+ <longdescription lang="en">Solarus is an open-source Zelda-like 2D game engine licensed under GPL. It is written in C++ and runs quests scripted in Lua.</longdescription>
</pkgmetadata>
diff --git a/games-engines/solarus/solarus-1.0.4.ebuild b/games-engines/solarus/solarus-1.0.4.ebuild
new file mode 100644
index 0000000..0142e1f
--- /dev/null
+++ b/games-engines/solarus/solarus-1.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games cmake-utils
+
+DESCRIPTION="An open-source Zelda-like 2D game engine"
+HOMEPAGE="http://www.solarus-games.org/"
+SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ media-libs/libmodplug
+ media-libs/libvorbis
+ dev-lang/lua
+ media-libs/openal
+ dev-games/physfs
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/games-rpg/zsdx/Manifest b/games-rpg/zsdx/Manifest
new file mode 100644
index 0000000..0acc49a
--- /dev/null
+++ b/games-rpg/zsdx/Manifest
@@ -0,0 +1 @@
+DIST zsdx-1.6.2.tar.gz 11744669 SHA256 4a15839d3db98bc7c770eac5983e283223cb29a69f648f015d21c71ce32d850a SHA512 6cad6909c348824456f49a5e24761c8924fb385bc3de479422710ad2edc7e4c229591d8cbf51abe181480c14517abe992381da2b3701374a1d33ae19657e9991 WHIRLPOOL 055bd0267abd79f7219e6d9b73e49f161fefe74b9f54ca11681f2d8ee9c88b36cad49b1d92682207cf8ec25668fdf574227738cb69fb6fe2745aaec045a7423c
diff --git a/games-rpg/zsdx/metadata.xml b/games-rpg/zsdx/metadata.xml
new file mode 100644
index 0000000..45dbce1
--- /dev/null
+++ b/games-rpg/zsdx/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <longdescription lang="en">The Legend of Zelda: Mystery of Solarus DX is set to be a direct sequel to The Legend of Zelda: A Link to the Past on the SNES, using the same graphics and game mechanisms. Zelda Mystery of Solarus DX is the first game made with the Solarus engine and in fact, Solarus was primarily designed for this game.</longdescription>
+</pkgmetadata>
diff --git a/games-rpg/zsdx/zsdx-1.6.2.ebuild b/games-rpg/zsdx/zsdx-1.6.2.ebuild
new file mode 100644
index 0000000..7ef37bd
--- /dev/null
+++ b/games-rpg/zsdx/zsdx-1.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games cmake-utils
+
+DESCRIPTION="A free 2D Zelda fangame"
+HOMEPAGE="http://www.solarus-games.org/"
+SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="=games-engines/solarus-1.0.4"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry ${PN} "Zelda: Mystery of Solarus DX"
+}
diff --git a/x11-apps/grandr/Manifest b/x11-apps/grandr/Manifest
deleted file mode 100644
index a0938e5..0000000
--- a/x11-apps/grandr/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST grandr-0.1.tar.bz2 112282 RMD160 ea92ab98d79053be42e4b62b612d87d4413e3660 SHA1 906c45448bfd3c3c0d2f24d3c62ea9c7e0f4ce61 SHA256 92921baaf683a9efb058962191058232ca808c3cba135575ae1eb40ea7e072be
diff --git a/x11-apps/grandr/files/0.1-fix-combo-invalid-iterator.patch b/x11-apps/grandr/files/0.1-fix-combo-invalid-iterator.patch
deleted file mode 100644
index fdbf5a7..0000000
--- a/x11-apps/grandr/files/0.1-fix-combo-invalid-iterator.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/src/callbacks.c 2007-06-19 15:22:41.000000000 +0200
-+++ b/src/callbacks.c 2007-12-04 14:30:54.000000000 +0100
-@@ -158,9 +158,12 @@
- GtkTreeModel *model;
- GtkTreeIter iter;
- int mode_id;
-+ gboolean iter_ok;
-
- model = gtk_combo_box_get_model (combobox);
-- gtk_combo_box_get_active_iter (combobox, &iter);
-+ iter_ok = gtk_combo_box_get_active_iter (combobox, &iter);
-+ if(!iter_ok) return;
-+
- gtk_tree_model_get (model, &iter,
- COL_MODE_ID, &mode_id,
- -1);
diff --git a/x11-apps/grandr/files/0.1-fix-license-display.patch b/x11-apps/grandr/files/0.1-fix-license-display.patch
deleted file mode 100644
index 8ce24f3..0000000
--- a/x11-apps/grandr/files/0.1-fix-license-display.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/src/callbacks.c b/src/callbacks.c
-index 788ca52..f5a4bd4 100644
---- a/src/callbacks.c
-+++ b/src/callbacks.c
-@@ -377,17 +377,26 @@ on_about_btn_clicked (GtkButton *button,
- {
- gchar *authors[] = {"Ming Lin (ming.m.lin@intel.com)", NULL};
- gchar *comments = "This GUI is for RandR 1.2 setting\nming.m.lin@intel.com";
-- gchar *license = "RandR GUI is free software; you can redistribute it and/or modify\n \
--it under the terms of the GNU General Public License as published by\n \
--the Free Software Foundation; either version 2 of the License, or\n \
--(at your option) any later version.\n\n\
--RandR GUI is distributed in the hope that it will be useful,\n \
--but WITHOUT ANY WARRANTY; without even the implied warranty of\n \
--MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the\n \
--GNU General Public License for more details.\n\n\
--You should have received a copy of the GNU General Public License \n\
--along with RandR GUI; if not, write to the Free Software Foundation, Inc.,\n \
--59 Temple Place, Suite 330, Boston, MA 02111-1307 USA";
-+ gchar *license =
-+"Copyright © 2007 Intel Corporation\n"
-+"\n"
-+"Permission is hereby granted, free of charge, to any person obtaining a copy\n"
-+"of this software and associated documentation files (the “Software”), to deal\n"
-+"in the Software without restriction, including without limitation the rights\n"
-+"to use, copy, modify, merge, publish, distribute, sublicense, and/or sell\n"
-+"copies of the Software, and to permit persons to whom the Software is\n"
-+"furnished to do so, subject to the following conditions:\n"
-+"\n"
-+"The above copyright notice and this permission notice shall be included in\n"
-+"all copies or substantial portions of the Software.\n"
-+"\n"
-+"THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR\n"
-+"IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,\n"
-+"FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE\n"
-+"AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER\n"
-+"LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,\n"
-+"OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN\n"
-+"THE SOFTWARE.";
-
- gtk_show_about_dialog (root_window,
- "authors", authors,
diff --git a/x11-apps/grandr/files/0.1-fix-segfault-without-gconf-value.patch b/x11-apps/grandr/files/0.1-fix-segfault-without-gconf-value.patch
deleted file mode 100644
index fe4cad7..0000000
--- a/x11-apps/grandr/files/0.1-fix-segfault-without-gconf-value.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/grandr.c b/src/grandr.c
-index e3e619e..8f0980b 100644
---- a/src/grandr.c
-+++ b/src/grandr.c
-@@ -1381,7 +1381,7 @@ set_hotkeys_view (GtkListStore *hotkey_store)
- NULL);
- command = gconf_client_get_string(client, GCONF_KEY2,
- NULL);
-- if (strcmp(key, HOTKEY) == 0 && strcmp(command, APP_NAME) == 0) {
-+ if (key && strcmp(key, HOTKEY) == 0 && command && strcmp(command, APP_NAME) == 0) {
- gtk_toggle_button_set_active (hotkey_cbtn, TRUE);
- } else {
- gtk_toggle_button_set_active (hotkey_cbtn, FALSE);
diff --git a/x11-apps/grandr/files/0.1-outpus.patch b/x11-apps/grandr/files/0.1-outpus.patch
deleted file mode 100644
index c5ea6f5..0000000
--- a/x11-apps/grandr/files/0.1-outpus.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-# On branch master
-# Changes to be committed:
-# (use "git reset HEAD <file>..." to unstage)
-#
-# modified: grandr.glade
-# modified: src/interface.c
-#
-diff --git a/grandr.glade b/grandr.glade
-index f1f0f91..6c21a17 100644
---- a/grandr.glade
-+++ b/grandr.glade
-@@ -202,7 +202,7 @@ THE SOFTWARE.
- <child>
- <widget class="GtkLabel" id="label9">
- <property name="visible">True</property>
-- <property name="label" translatable="yes">Outpus </property>
-+ <property name="label" translatable="yes">Outputs </property>
- <property name="use_underline">False</property>
- <property name="use_markup">False</property>
- <property name="justify">GTK_JUSTIFY_LEFT</property>
-diff --git a/src/interface.c b/src/interface.c
-index 8cc1427..bee4b81 100644
---- a/src/interface.c
-+++ b/src/interface.c
-@@ -179,7 +179,7 @@ create_main_win (void)
- gtk_widget_show (vbox2);
- gtk_container_add (GTK_CONTAINER (viewport1), vbox2);
-
-- label9 = gtk_label_new (_("Outpus "));
-+ label9 = gtk_label_new (_("Outputs "));
- gtk_widget_show (label9);
- gtk_box_pack_start (GTK_BOX (vbox2), label9, FALSE, FALSE, 0);
-
diff --git a/x11-apps/grandr/grandr-0.1-r2.ebuild b/x11-apps/grandr/grandr-0.1-r2.ebuild
deleted file mode 100644
index 50c176b..0000000
--- a/x11-apps/grandr/grandr-0.1-r2.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/grandr/grandr-0.1-r1.ebuild,v 1.1 2012/04/14 16:28:34 mgorny Exp $
-
-EAPI=4
-inherit xorg-2
-
-DESCRIPTION="GTK+-based tool to configure the X output using the RandR 1.2 extension"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE=""
-RDEPEND="x11-libs/gtk+:2
- >=x11-libs/libXrandr-1.2
- gnome-base/gconf"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-fix-license-display.patch
- "${FILESDIR}"/${PV}-outpus.patch
- "${FILESDIR}"/${PV}-fix-segfault-without-gconf-value.patch
- "${FILESDIR}"/${PV}-fix-combo-invalid-iterator.patch
-)