aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAstroFloyd <AstroFloyd@gmail.com>2016-11-05 08:44:42 +0100
committerAstroFloyd <AstroFloyd@gmail.com>2016-11-05 08:44:42 +0100
commit2efd15f36e771992257a823706485115bad7c2ee (patch)
tree00d236b296cb7d9509a5efb7888669794008661a /sci-libs/fgsl/fgsl-0.9.ebuild
parentvmware-horizon-client-bin: installation works, program runs, but can't connect (diff)
downloadAstroFloyd-2efd15f36e771992257a823706485115bad7c2ee.tar.gz
AstroFloyd-2efd15f36e771992257a823706485115bad7c2ee.tar.bz2
AstroFloyd-2efd15f36e771992257a823706485115bad7c2ee.zip
sci-libs/fgsl: fixed ebuilds: remove use() statement from global scope
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-libs/fgsl/fgsl-0.9.ebuild')
-rw-r--r--sci-libs/fgsl/fgsl-0.9.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/sci-libs/fgsl/fgsl-0.9.ebuild b/sci-libs/fgsl/fgsl-0.9.ebuild
index e0cd020..e2dca30 100644
--- a/sci-libs/fgsl/fgsl-0.9.ebuild
+++ b/sci-libs/fgsl/fgsl-0.9.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=5
inherit eutils
DESCRIPTION="A Fortran interface to the GNU Scientific Library"
@@ -10,7 +11,8 @@ SRC_URI="http://www.lrz-muenchen.de/services/software/mathematik/gsl/fortran/${P
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+#KEYWORDS="~amd64 ~x86"
+KEYWORDS="~x86" # ifc can't have ~amd64 keyword?
#IUSE="gfortran ifort" #Compiler gfortran does not (properly) support ISO_C_BINDING
IUSE="ifort"
@@ -20,22 +22,21 @@ RDEPEND=${DEPEND}
DESTDIR="/usr"
-BITS="32"
-if use amd64; then
- BITS="64"
-fi
-
-
-
src_unpack() {
unpack ${A}
- cd "${S}"
+}
+
+src_prepare() {
epatch "${FILESDIR}"/${P}-configure.patch #Allows the use of econf
epatch "${FILESDIR}"/${P}-Makefile.patch #Makes make more verbose
}
-
src_compile() {
+ BITS="32"
+ if use amd64; then
+ BITS="64"
+ fi
+
if use ifort; then
econf --prefix ${DESTDIR} --gsl ${DESTDIR} --f90 ifort --bits ${BITS}
#elif use gfortran; then
@@ -56,4 +57,3 @@ pkg_config()
{
eerror "This ebuild does not have a config function."
}
-