aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylibacl/pylibacl-0.5.3-r1.ebuild')
-rw-r--r--dev-python/pylibacl/pylibacl-0.5.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pylibacl/pylibacl-0.5.3-r1.ebuild b/dev-python/pylibacl/pylibacl-0.5.3-r1.ebuild
new file mode 100644
index 0000000..c696cf9
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.5.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="https://pylibacl.k1024.org/
+ https://pypi.org/project/pylibacl/"
+SRC_URI="https://github.com/iustin/${PN}/archive/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="sys-apps/acl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${PN}-v${PV}"
+
+python_test() {
+ if ! "${EPYTHON}" test/test_acls.py -v; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}