summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/shellinabox/shellinabox-2.10.ebuild')
-rw-r--r--app-admin/shellinabox/shellinabox-2.10.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-admin/shellinabox/shellinabox-2.10.ebuild b/app-admin/shellinabox/shellinabox-2.10.ebuild
deleted file mode 100644
index 850189d..0000000
--- a/app-admin/shellinabox/shellinabox-2.10.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header$
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="Web based AJAX terminal emulator"
-HOMEPAGE="http://code.google.com/p/shellinabox"
-SRC_URI="http://shellinabox.googlecode.com/files/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2.0"
-KEYWORDS="~x86 ~amd64"
-
-IUSE="+ssl"
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.8 )"
-DEPEND="${RDEPEND}"
-
-pkg_setup()
-{
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 "${PN}"
-}
-
-src_configure()
-{
- econf \
- $(use_enable ssl) \
- || die "econf failed"
-}
-
-src_install()
-{
- emake DESTDIR="${D}" install || die "einstall failed"
-
- dodir "/var/lib/${PN}"
- fowners ${PN}:${PN} "/var/lib/${PN}"
-
- newinitd "${FILESDIR}"/${PN}-init ${PN}
- newconfd "${FILESDIR}"/${PN}-conf ${PN}
-}
-