summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-05-02 22:05:54 +0200
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-05-02 22:05:54 +0200
commit329b653aa0fed22d969d6e99b99b8f54bce7b74c (patch)
tree0facba990b286be9bf136dc982eee221de54119b
parent+apitrace-1.0.ebuild (diff)
downloadaluco-329b653aa0fed22d969d6e99b99b8f54bce7b74c.tar.gz
aluco-329b653aa0fed22d969d6e99b99b8f54bce7b74c.tar.bz2
aluco-329b653aa0fed22d969d6e99b99b8f54bce7b74c.zip
+phoronix-test-suite-3.2.0_beta2-r1.ebuild
Clean up the php dependencies.
-rw-r--r--app-benchmarks/phoronix-test-suite/Manifest2
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.2.0_beta2-r1.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/app-benchmarks/phoronix-test-suite/Manifest b/app-benchmarks/phoronix-test-suite/Manifest
index 646bc89..c6ed34e 100644
--- a/app-benchmarks/phoronix-test-suite/Manifest
+++ b/app-benchmarks/phoronix-test-suite/Manifest
@@ -6,4 +6,6 @@ EBUILD phoronix-test-suite-3.0.0.ebuild 1822 RMD160 e9b148ffe0434b9884a4e2d4b07d
EBUILD phoronix-test-suite-3.0.1-r1.ebuild 2273 RMD160 8067ac41faebdc6544f2a7b8d0605dc06f2d5d2d SHA1 4f6a00fa5f7cafdfa83e3094f9613d7a41a9ba36 SHA256 87ee0bfd6f4b1c44758576febff77bfae4b630961eb42a493985652dffa39dd0
EBUILD phoronix-test-suite-3.0.1.ebuild 2334 RMD160 01c356023775232d65dabc115c27fbb97ed45952 SHA1 bded3d6c4641d3a58c2cb3b2c9972ee6d5facc53 SHA256 8570a8e9fe1fa029bb5986fdd1a21b9280d606e042025d5f263e0b618c79494c
EBUILD phoronix-test-suite-3.2.0_beta1.ebuild 2318 RMD160 87abfebe132c1d5cc8e369889b6d9b01a34e53d7 SHA1 2d153a79335caccda88dd60ce350bb1f81dd6f62 SHA256 3c284eb77c9dcd34fbaecacf1ac87e4edb709e239e8db199c5547282522f3318
+EBUILD phoronix-test-suite-3.2.0_beta2-r1.ebuild 3340 RMD160 f356d7732274b4f1a833be2aecc1cfc592d56f7e SHA1 dd8fabae39cb44e3d5a0edbccb29c8ac6bc481ac SHA256 35565ca26ceca33482dc2f2964b6e985d62fe2f4cea5ae6256b2536b82327f68
EBUILD phoronix-test-suite-3.2.0_beta2.ebuild 2179 RMD160 605df0c6a1553054561a79571aa384500714999b SHA1 3817d0e0449972a176637b6f46e7a5b263fbba0f SHA256 d0c6bccc4d089141e9dd0e73901982cd539aaa603b90ba2aad035f157405b5f4
+MISC TODO.txt 77 RMD160 02f4ac12783203563ebba689cc9d563b253dc4e3 SHA1 95864e71e10fb0e71f423b7f5d2772b15b2f1d5c SHA256 2440b760c93412c40017c26de196fdb48856c81158c7c400bfc36321c3b56287
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.2.0_beta2-r1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.2.0_beta2-r1.ebuild
new file mode 100644
index 0000000..566230e
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.2.0_beta2-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils bash-completion
+
+DESCRIPTION="Phoronix's comprehensive, cross-platform testing and benchmark suite"
+HOMEPAGE="http://www.phoronix-test-suite.com"
+MY_PV="${PN}-3.2.0m2"
+SRC_URI="http://www.phoronix-test-suite.com/download.php?file=development/${MY_PV} -> ${MY_PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+DEPEND=""
+
+# php 5.3 doesn't have pcre and reflection useflags anymore
+# php-gtk doesn't support php 5.3 at once
+RDEPEND="!gtk? ( || ( dev-lang/php:5.3[cli,curl,gd,posix,pcntl,truetype,zip] dev-lang/php:5.2[cli,curl,gd,posix,pcntl,reflection,truetype,pcre,zip] ) )
+ gtk? ( dev-lang/php:5.2[cli,curl,gd,posix,pcntl,reflection,truetype,pcre,zip]
+ dev-php5/php-gtk )
+ dev-php5/pecl-ps"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
+ phoronix-test-suite
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+
+ doman documentation/man-pages/phoronix-test-suite.1
+ dodoc AUTHORS CHANGE-LOG COPYING documentation/phoronix-test-suite.pdf
+ dohtml -r documentation/
+ dobashcompletion pts-core/static/bash_completion ${PN}
+ doicon pts-core/static/images/phoronix-test-suite.png
+ doicon pts-core/static/images/openbenchmarking.png
+ domenu pts-core/static/phoronix-test-suite.desktop
+ rm -f pts-core/static/phoronix-test-suite.desktop
+
+ doins -r {pts,pts-core}
+ exeinto /usr/bin
+ doexe phoronix-test-suite
+
+ #fperms a+x /usr/share/${PN}/pts/test-resources/*/*.sh
+ #fperms a+x /usr/share/${PN}/pts/base-test-resources/*/*.sh
+ #fperms a+x /usr/share/${PN}/pts-core/modules/*.sh
+ #fperms a+x /usr/share/${PN}/pts-core/test-libraries/*.sh
+ fperms a+x /usr/share/${PN}/pts-core/static/scripts/root-access.sh
+ fperms a+x /usr/share/${PN}/pts-core/external-test-dependencies/scripts/install-gentoo-packages.sh
+
+ # Need to fix the cli-php config for downloading to work. Very naughty!
+ local slots
+ local slot
+ if use gtk ; then
+ slots="php5.2"
+ else
+ if [[ "x${PHP_TARGETS}" == "x" ]] ; then
+ ewarn
+ ewarn "PHP_TARGETS seems empty, php.ini file can't be configure."
+ ewarn "Make sure that PHP_TARGETS in /etc/make.conf is set."
+ ewarn
+ else
+ for slot in ${PHP_TARGETS}; do
+ slots+=" ${slot/-/.}"
+ done
+ fi
+ fi
+
+ for slot in ${slots}; do
+ local PHP_INI_FILE="/etc/php/cli-${slot}/php.ini"
+ if [[ -f ${PHP_INI_FILE} ]] ; then
+ dodir $(dirname ${PHP_INI_FILE})
+ cp ${PHP_INI_FILE} "${D}${PHP_INI_FILE}"
+ sed -e 's|^allow_url_fopen .*|allow_url_fopen = On|g' -i "${D}${PHP_INI_FILE}"
+ else
+ if [[ "x$(eselect php show cli)" == "x${slot}" ]] ; then
+ ewarn
+ ewarn "${slot} hasn't a php.ini file."
+ ewarn "phoronix-test-suite needs the allow_url_fopen option set to \"On\""
+ ewarn "for downloading to work properly."
+ ewarn "Check that your PHP_INI_VERSION is set during ${slot} merge"
+ ewarn
+ else
+ einfo
+ einfo "${slot} hasn't a php.ini file."
+ einfo "phoronix-test-suite may need the allow_url_fopen option set to \"On\""
+ einfo "for downloading to work properly if you switch to ${slot}"
+ einfo "Check that your PHP_INI_VERSION is set during ${slot} merge"
+ einfo
+ fi
+ fi
+ done
+}