summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2014-01-18 10:48:50 +0100
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2014-01-18 10:48:50 +0100
commit4f7240e2d884c19d9e8785872e6a9f7940bca92b (patch)
tree5597cea8284f8da829ec57819b8f8b86084ee4d6 /dev-util/radare2/radare2-0.9.6.ebuild
parentFollow new portage features (diff)
downloadaluco-4f7240e2d884c19d9e8785872e6a9f7940bca92b.tar.gz
aluco-4f7240e2d884c19d9e8785872e6a9f7940bca92b.tar.bz2
aluco-4f7240e2d884c19d9e8785872e6a9f7940bca92b.zip
+radare2-0.9.6.ebuild
- initial ebuild
Diffstat (limited to 'dev-util/radare2/radare2-0.9.6.ebuild')
-rw-r--r--dev-util/radare2/radare2-0.9.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/radare2/radare2-0.9.6.ebuild b/dev-util/radare2/radare2-0.9.6.ebuild
new file mode 100644
index 0000000..9c8138a
--- /dev/null
+++ b/dev-util/radare2/radare2-0.9.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+inherit base eutils
+
+DESCRIPTION="Advanced command line hexadecimal editor and more"
+HOMEPAGE="http://www.radare.org"
+SRC_URI="http://www.radare.org/get/radare2-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+#IUSE="cparse debugger sysmagic ewf ssl"
+IUSE="cparse debugger ewf ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ ewf? ( app-forensics/libewf )
+ "
+#sysmagic? ( sys-libs/libmagic )
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myconf=""
+ use cparse && myconf="${myconf} $(use_enable cparse)"
+ use debugger || myconf="${myconf} $(use_enable debugger)"
+ #use sysmagic && myconf="${myconf} $(use_with sysmagic)"
+ use ewf || myconf="${myconf} $(use_with ewf)"
+ use ssl && myconf="${myconf} $(use_with ssl openssl)"
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_PROGRAM="install" install || die "install failed"
+}