summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2014-10-13 23:15:13 +0200
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2014-10-13 23:15:13 +0200
commit49014e270db88f5def970924b6c0d328a802a47b (patch)
treea5b293f1679ba3e9dd47fb83d2dfa90bb9e93f00 /games-simulation/corewars/corewars-0.9.13-r1.ebuild
parent+corewars-0.9.13-r1.ebuild (diff)
downloadaluco-49014e270db88f5def970924b6c0d328a802a47b.tar.gz
aluco-49014e270db88f5def970924b6c0d328a802a47b.tar.bz2
aluco-49014e270db88f5def970924b6c0d328a802a47b.zip
corewars-0.9.13-r1.ebuild
Add debug use flag and fix QA warnings.
Diffstat (limited to 'games-simulation/corewars/corewars-0.9.13-r1.ebuild')
-rw-r--r--games-simulation/corewars/corewars-0.9.13-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/games-simulation/corewars/corewars-0.9.13-r1.ebuild b/games-simulation/corewars/corewars-0.9.13-r1.ebuild
index 33b1342..552d250 100644
--- a/games-simulation/corewars/corewars-0.9.13-r1.ebuild
+++ b/games-simulation/corewars/corewars-0.9.13-r1.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit games
+inherit autotools games
DESCRIPTION="Simulation game involving virtual machine code"
HOMEPAGE="http://corewars.sourceforge.net/"
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
KEYWORDS="~amd64 ~x86"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+IUSE="debug"
RDEPEND=">=x11-libs/gtk+-2:2"
DEPEND="${RDEPEND}"
@@ -22,6 +22,12 @@ DEPEND="${RDEPEND}"
src_prepare() {
epatch "${DISTDIR}"/${PN}-gtk2.patch.gz
epatch "${FILESDIR}"/${PV}-corewars-lm.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug gcc-debug)
}
src_install() {