summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2014-10-14 23:21:09 +0200
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2014-10-14 23:21:09 +0200
commitb682f1efe3d8953d9c0a23445c6dbf808fa9b6cd (patch)
tree1b404fcfd8e4df639334c9507d070b95ac2822cd /games-simulation/corewars/corewars-0.9.13-r1.ebuild
parentcorewars-0.9.13-r1.ebuild (diff)
downloadaluco-b682f1efe3d8953d9c0a23445c6dbf808fa9b6cd.tar.gz
aluco-b682f1efe3d8953d9c0a23445c6dbf808fa9b6cd.tar.bz2
aluco-b682f1efe3d8953d9c0a23445c6dbf808fa9b6cd.zip
corewars-0.9.13-r1.ebuild
- add a new corewars robot - fix egamesconf - fix a crash when try to load a new robot's directory
Diffstat (limited to 'games-simulation/corewars/corewars-0.9.13-r1.ebuild')
-rw-r--r--games-simulation/corewars/corewars-0.9.13-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-simulation/corewars/corewars-0.9.13-r1.ebuild b/games-simulation/corewars/corewars-0.9.13-r1.ebuild
index 552d250..a369dfd 100644
--- a/games-simulation/corewars/corewars-0.9.13-r1.ebuild
+++ b/games-simulation/corewars/corewars-0.9.13-r1.ebuild
@@ -22,16 +22,20 @@ DEPEND="${RDEPEND}"
src_prepare() {
epatch "${DISTDIR}"/${PN}-gtk2.patch.gz
epatch "${FILESDIR}"/${PV}-corewars-lm.patch
+ epatch "${FILESDIR}"/${PV}-fix-get_current_dir_name-prototype.patch
eautoreconf
}
+
src_configure() {
- econf $(use_enable debug gcc-debug)
+ egamesconf $(use_enable debug gcc-debug)
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins "${FILESDIR}/reroute.cw"
dodoc ChangeLog README doc/{TODO,DIFFERENCES,INTERESTING-COMBINATIONS}
prepgamesdirs
}