summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/radare2/radare2-0.9.9.ebuild')
-rw-r--r--dev-util/radare2/radare2-0.9.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/radare2/radare2-0.9.9.ebuild b/dev-util/radare2/radare2-0.9.9.ebuild
new file mode 100644
index 0000000..21f66f9
--- /dev/null
+++ b/dev-util/radare2/radare2-0.9.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Advanced command line hexadecimal editor and more"
+HOMEPAGE="http://www.radare.org"
+SRC_URI="http://www.radare.org/get/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="cparse debug debugger ssl sysmagic zlib"
+IUSE="cparse debug debugger ssl"
+
+RDEPEND=">=dev-util/capstone-3.0
+ ssl? ( dev-libs/openssl:= )
+"
+#sysmagic? ( sys-libs/libmagic )
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_with ssl openssl) \
+ $(use_enable cparse) \
+ $(use_enable debug) \
+ $(use_enable debugger) \
+ --with-syscapstone
+}