summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch')
-rw-r--r--media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch b/media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch
new file mode 100644
index 0000000..616dcc8
--- /dev/null
+++ b/media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch
@@ -0,0 +1,42 @@
+--- configure.ac.orig 2011-05-04 00:17:15.370171000 +0200
++++ configure.ac 2011-05-04 00:26:27.583170991 +0200
+@@ -93,18 +93,35 @@ AC_C_INLINE
+ AC_FUNC_MALLOC
+ AC_CHECK_FUNCS([floor memset pow sqrt])
+
++
++AC_ARG_ENABLE([facedetect], [ --enable-facedetect enable facedetect plugin (needs opencv)],
++ [facedetect=${enableval}], [facedetect=no])
++
+ HAVE_OPENCV=false
+-PKG_CHECK_MODULES(OPENCV, opencv >= 1.0.0, [HAVE_OPENCV=true], [true])
+-AM_CONDITIONAL([HAVE_OPENCV], [test x$HAVE_OPENCV = xtrue])
+-if test x$HAVE_OPENCV = xtrue; then
++if test "x${facedetect}" = xyes; then
++ PKG_CHECK_MODULES(OPENCV, opencv >= 1.0.0, [HAVE_OPENCV=true], [true])
++ if test x$HAVE_OPENCV = xtrue; then
+ # OPENCV_CFLAGS="$OPENCV_CFLAGS -DOPENCV_PREFIX=`pkg-config opencv --variable=prefix`"
+ AC_DEFINE(HAVE_OPENCV,1,[compiled including opencv])
+ AC_DEFINE(OPENCV_DATA_DIR,[${prefix}/share/opencv],opencv data prefix)
++ else
++ AC_MSG_WARN([*** opencv >= 1.0.0 not found - this program enables optional plugin with the Open Source Computer Vision library >= 1.0.0 http://opencvlibrary.sourceforge.net/ ***])
++ fi
+ fi
++AM_CONDITIONAL([HAVE_OPENCV], [test x$HAVE_OPENCV = xtrue])
+ AC_SUBST(HAVE_OPENCV)
+
++
++AC_ARG_ENABLE([scale0tilt], [ --enable-scale0tilt enable scale0tilt plugin (needs gavl)],
++ [scale0tilt=${enableval}], [scale0tilt=no])
++
+ HAVE_GAVL=false
+-PKG_CHECK_MODULES(GAVL, gavl >= 0.2.3, [HAVE_GAVL=true], [true])
++if test "x${scale0tilt}" = xyes; then
++ PKG_CHECK_MODULES(GAVL, gavl >= 0.2.3, [HAVE_GAVL=true], [true])
++ if test x$HAVE_GAVL = xfalse; then
++ AC_MSG_WARN([*** gavl >= 0.2.3 not found - this program enables optional plugin with the gmerlin audio video library >= 0.2.3 http://gmerlin.sourceforge.net/ ***])
++ fi
++fi
+ AM_CONDITIONAL([HAVE_GAVL], [test x$HAVE_GAVL = xtrue])
+
+ AC_CHECK_PROG([DOXYGEN], [doxygen], [doxygen])